Opened 11 years ago

Closed 11 years ago

#1804 closed Bug (duplicate)

IE7: "colspan" collapses editor when swithching between Source View/Wikitext

Reported by: hans88 Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version:
Keywords: Confirmed IE7 Cc:

Description

Difficult to reproduce (the problem depends on the content of the article). in my article i had some pictures in a table. if i work on the article with firefox everythings fine. but on edit with Internet Explorer 7 i can't change to Source-Code (or Wikitext) and after saving again all pictures are gone. instead of the pictures there's something like this: <img src="ef=" _fck_mw_filename="pic.jpg" alt="80px" /> besides all links are changed to <a href="linkdestiation.html">Linkdestination</a> but this happens only very rarely. but if it happens IE7 brings the error messeage "Object Does Not Support Property Or Method" URL:mywikipath/extensions/FCKeditor/editor/fckeditor.html?InstanceName=wpTextbox1&Toolbar=Wiki I've no idea how to resolve this problem. so please help me!!! I use this version of the FCKeditor: http://www.mediawiki.org/wiki/Extension:FCKeditor_%28by_FCKeditor_and_Wikia%29

Attachments (1)

example.xml (2.5 KB) - added by hans88 11 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 11 years ago by hans88

I use MediaWiki 1.11.0

comment:2 Changed 11 years ago by Wojciech Olchawa

Component: Server : PHPProject : MediaWiki+FCKeditor
Keywords: IE7 removed
Priority: HighNormal

comment:3 Changed 11 years ago by Wojciech Olchawa

Keywords: Pending added

Hi! Could you provide us a sample page with the problem that you are dealing with. As you said the problem is hard to reproduce so we were unable to reproduce your problem.

Thanks

comment:4 Changed 11 years ago by hans88

In the meantime I found out that the problem is connected apparently with tables. if a cell is divided into two colums the problem described above arises. here is a example (the wiki-syntax of an article)

Example

{| cellspacing="1" cellpadding="1" border="1" style="width: 772px; height: 190px;"

| cell 1 | colspan="2" | cell 2 | cell 3

| cell 4 | colspan="2" | cell 5 with a picture [[Image:Pic.jpg|50px]]<br> | cell 6

| cell 7 | cell 8_1 | cell&nbsp; 8_2 | cell 9

| cell 10 | colspan="2" | cell 11 | cell 12 with a link<br> |}

Changed 11 years ago by hans88

Attachment: example.xml added

comment:5 Changed 11 years ago by Wojciech Olchawa

Keywords: Confirmed IE7 added; Pending removed
Summary: IE7 Source or Wikitext problem/error, Images are replaced to FCK-Source-CodeIE7: "colspan" collapses editor when swithching between Source View/Wikitext

Confirmed

It took me a while to find the origin of the problem. It seems that it isn't the pictures and the links which are breaking the IE7. It seems that the

colspan="2" 

is breaking down the code. If you delete it everything works fine. We will try to work it out somehow. Thanks for the example it was very useful.

comment:6 Changed 11 years ago by Wojciech Olchawa

Resolution: duplicate
Status: newclosed

DUP of #1214

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy