Ticket #1214 (closed Bug: worksforme)

Opened 7 years ago

Last modified 6 years ago

IE: "colspan" collapses wikitext.

Reported by: dantheman2 Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version: SVN (FCKeditor) - Retired
Keywords: Confirmed IE Cc:

Description

When editing pages using IE6, the wikitext button does not work, pre-exisiting content that used an older FCKEditor conaining spanned table columns cannot be edited in the rich editor. Also, links get duplicated over and over in pages of this type. A java script error occurs when clicking the wikitext button. The error is object does not support this property or method. See the discussion page on the MediWiki+FCKEditor.

Firefox works correctly.

Change History

comment:1 Changed 6 years ago by w.olchawa

  • Keywords Confirmed added
  • Version changed from FCKeditor 2.4.3 to SVN
  • Summary changed from IE 6 and MediaWiki -- certain pages cannot be edited that contain spanned column tables to IE: "colspan" collapses wikitext.

Confirmed

I was able to reproduce the problem on IE7. On IE6 my result was that the columns are some of the columns are deleted.

IE6(example from #1804):

{| cellspacing="1" cellpadding="1" border="1" style="width: 772px; height: 190px;" |- | cell 1 | colspan="2" | cell 2 | cell 3 |- | cell 4 | colspan="2" | cell 5 with a picture [[Image:Pic.jpg|50px]]<br> | cell 6 |- | cell 7 | cell 8_1 | cell&nbsp; 8_2 | cell 9 |- | cell 10 | colspan="2" | cell 11 | cell 12 with a link<br> |}

is transformed to this:

{| cellspacing="1" cellpadding="1" border="1" style="width: 772px; height: 190px;" |- | cell 1 | colspan="2" | cell 2 | cell 3 |- | cell 4 | colspan="2" | cell 5 with a picture [[Image:Pic.jpg|50px]]<br> | cell 6 |- | cell 7 | cell 8_1 | cell&nbsp; 8_2 | cell 9 |- | cell 10 | colspan="2" | cell 11 | cell 12 with a link<br> |}

IE7: as in your description the browser stops responding when clicking on source view/wikitext.

FF2: everything works fine

More information about this bug in #1804

#1804 was marked as DUP

comment:2 Changed 6 years ago by w.olchawa

sorry...I've pasted the same example twice. In IE6 it should be:

is transformed to this:

{| cellspacing="1" cellpadding="1" border="1"
|-
| 
|}

comment:3 Changed 6 years ago by w.olchawa

#2010 has been marked as DUP

comment:4 Changed 6 years ago by wwalc

Corrected IE6 example (with line breaks):

{| cellspacing="1" cellpadding="1" border="1" style="width: 772px; height:
 190px;"
 |-
 | cell 1
 | colspan="2" | cell 2
 | cell 3
 |-
 | cell 4
 | colspan="2" | cell 5 with a picture [[Image:Pic.jpg|50px]]<br>
 | cell 6
 |-
 | cell 7
 | cell 8_1
 | cell&nbsp; 8_2
 | cell 9
 |-
 | cell 10
 | colspan="2" | cell 11
 | cell 12 with a [http://www.google.de link]<br>
 |}

comment:5 Changed 6 years ago by wwalc

Ignore last comment..., corrected example :

{| cellspacing="1" cellpadding="1" border="1" style="width: 772px; height: 190px;"
 |-
 | cell 1
 | colspan="2" | cell 2
 | cell 3
 |-
 | cell 4
 | colspan="2" | cell 5 with a picture [[Image:Pic.jpg|50px]]<br>
 | cell 6
 |-
 | cell 7
 | cell 8_1
 | cell&nbsp; 8_2
 | cell 9
 |-
 | cell 10
 | colspan="2" | cell 11
 | cell 12 with a [http://www.google.de link]<br>
 |}

comment:6 Changed 6 years ago by wwalc

  • Status changed from new to closed
  • Resolution set to worksforme

Can't reproduce this issue using the latest version of FCKeditor extension (FCKeditor 2.5.1 included).

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy