Opened 11 years ago

Closed 7 years ago

#1819 closed Bug (fixed)

Fitwindow bug when editor in relative positioned and auto overflowing div

Reported by: Paul Moers Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.5.1
Keywords: Cc:

Description

When toggling to fullscreen by using the fitWindow plugin, the editor will not break out of a relative positioned and auto overflowing div. Also, when making the editor's default height a 100%, the editor will overflow the div instead of fitting nicely into it. The attached file can be placed inside \fckeditor\_samples to see the bug.

Tested in IE6+7, firefox, Safari 3.0.4 on windows and Opera 9.50 beta where the behavior was almost the same for all browsers. Only in Opera and Safari, setting the height to 100% will not overflow the div, but just makes the editor higher.

Attachments (1)

fitWindow_in_relative_positioned_and_auto_overflowing_div.html (1.8 KB) - added by Paul Moers 11 years ago.
Test case file

Download all attachments as: .zip

Change History (3)

Changed 11 years ago by Paul Moers

Test case file

comment:1 Changed 11 years ago by Wojciech Olchawa

Keywords: Confirmed added
Version: FCKeditor 2.5.1

comment:2 Changed 7 years ago by Krzysztof Studnik

Resolution: fixed
Status: confirmedclosed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy