Opened 10 years ago

Closed 6 years ago

#1818 closed Bug (fixed)

IE:Editor shuffles content

Reported by: alexanderv Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.5.1
Keywords: IE Cc:

Description

Browser: IE 7, OS: Windows 2003

When inserting formatted data from some applications (including Eclipse, Visual Studio,...) via the clipboard, FCKeditor may rearrange these data and render them useless.

It seems that the call to execCommand('Paste') produces invalid HTML that FCKeditor, in contrast to browsers, cannot handle.

This phenomenon can be studied by with the sample below. Paste it into the source view of FCKeditor and switch between source and HTML view. More complex input leads to more stunning results.


<p> <font color="#008000" size="2"> <p>-------------------------------------------------------</p> <p> ABOVE</p> <p>-------------------------------------------------------</p> </font> <p>BELOW</p> </p>

Change History (3)

comment:1 Changed 10 years ago by Wojciech Olchawa

Keywords: Confirmed IE added; clipboard copy&paste invalid html removed
Summary: Editor shuffles contentIE:Editor shuffles pasted content
Version: FCKeditor 2.4.3FCKeditor 2.5.1

Confirmed on IE and IE7. The example shown by alexanderv is being transformed to this:


<p> <p>BELOW</p> <p>&nbsp;</p> </p> <p>-------------------------------------------------------</p> <p> ABOVE</p> <p>-------------------------------------------------------</p>


The lines are shuffled.

comment:2 Changed 10 years ago by Wojciech Olchawa

Summary: IE:Editor shuffles pasted contentIE:Editor shuffles content

#1827 has been marked as DUP

comment:3 Changed 6 years ago by Piotrek Koszuliński

Resolution: fixed
Status: confirmedclosed

This issue nearly expired since we've got completely custom pasting handling. The last part of it is data filtering which is targeted by #9829.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy