Ticket #8000 (closed Bug: fixed)

Opened 3 years ago

Last modified 3 years ago

Problem with SCAYT and languages sample.

Reported by: j.swiderski Owned by:
Priority: Normal Milestone: CKEditor 3.6.1
Component: General Version: 3.6.1
Keywords: Cc:

Description

  1. Open languages sample,
  2. Enable SCAYT,
  3. Wait until SCAYT underlines words from sample text
  4. Try to change the language.

Result: JS error pops out: "x.config.skin is undefined"

In my TC, editor was loaded with Polish locale, after enablig SCAYT, CKEditor link was underlined, I changed the language to Greek. As soon as I find revision I will post it with more detailed error description.

As soon as I find revision I will post it with more detailed error description.

Change History

comment:1 Changed 3 years ago by j.swiderski

  • Status changed from new to confirmed

comment:2 Changed 3 years ago by wwalc

  • Milestone set to CKEditor 3.6.1

comment:3 Changed 3 years ago by j.swiderski

I have encountered some problems when trying to find the exact revision number.

Here is what I have found out:
Issue works fine in [6908].
Issue is definitely broken in [6914]
In revisions [6909] - [6913] the editor is simply not loading.

So the error has occurred in one of [6909]-[6914]

NOTE: This is only reproducible in release version so I can't give you any exact JS error either.

comment:4 Changed 3 years ago by wwalc

It looks like it is caused by [6912] (?). Confirmed using release version of CKEditor rev. 6008 with change from [6912].

comment:5 Changed 3 years ago by garry.yao

  • Status changed from confirmed to closed
  • Resolution set to fixed

Looks like a CKPackager bug which leaks global variable from for loop, as we're rushing on the release, I'm simply fixing the code here with [7021].

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy