Opened 10 years ago

Closed 10 years ago

#1832 closed Bug (fixed)

[FF] No placeholder for flash/embed tag

Reported by: eallik Owned by: Martin Kou
Priority: Normal Milestone: FCKeditor 2.6
Component: General Version: SVN (FCKeditor) - Retired
Keywords: Confirmed Firefox Review+ Cc:

Description

In Firefox 2, when inserting the HTML below, a placeholder does not appear, After switching to the source view and back to the WYSIWYG view, though, a placeholder does appear.

<span class="embedded-object-18-408"><embed width="300" height="225" allowfullscreen="true" type="application/x-shockwave-flash" flashvars="&amp;image=/picserver/s/orig/public/video/water_balloon_11.mpeg.flv0000.jpg&amp;file=/picserver/s/video/public/water_balloon_11.mpeg.flv" src="../../videoplayer/mediaplayer.swf?0.4076338401231444"></embed></span>

Attachments (1)

1832.patch (1.2 KB) - added by Martin Kou 10 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Firefox added
Milestone: FCKeditor 2.6
Version: SVN

Not confirmed, but I've noted that the call to FCKDocumentProcessor.Process( FCK.EditorDocument ) is not being done in FCK.InsertHtml at fck_gecko.js, while is it properly called in fck_ie.js.

comment:2 Changed 10 years ago by Frederico Caldeira Knabben

Btw... for "inserting the HTML below", the reporter means "inserting the HTML below with InsertHtml" (taken from IRC).

comment:3 Changed 10 years ago by Wojciech Olchawa

#1848 has been marked as DUP

comment:4 Changed 10 years ago by Wojciech Olchawa

Keywords: Confirmed added
Summary: In firefox, no placeholder for flash/embed tag[FF] No placeholder for flash/embed tag

Confirmed in FF2. Works in IE.

comment:5 Changed 10 years ago by Martin Kou

Owner: set to Martin Kou
Status: newassigned

Since #922 is requesting a general revamp of the <embed>/<object> processing system, this ticket is related to #922.

Changed 10 years ago by Martin Kou

Attachment: 1832.patch added

comment:6 Changed 10 years ago by Martin Kou

Keywords: Review? added

comment:7 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

comment:8 Changed 10 years ago by Martin Kou

Resolution: fixed
Status: assignedclosed

Fixed with [1741].

Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy