Ticket #1835 (closed Bug: fixed)

Opened 6 years ago

Last modified 5 years ago

Embed tag src attribute value appears to be modified by InsertHtml

Reported by: eallik Owned by:
Priority: Normal Milestone: CKEditor 3.0
Component: General Version:
Keywords: Confirmed Cc:

Description

Inserting HTML using InsertHtml results in the src URL attribute being replaced by a site root relative path.

The following HTML:

<embed type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" src="http://delfi.laborint.com/r/videoplayer/mediaplayer.swf?0.07093275174449953" play="true" loop="true" menu="true" flashvars="&image=/picserver/s/orig/public/video/water_balloon_copy_24.mpeg.flv0000.jpg&file=/picserver/s/video/public/water_balloon_copy_24.mpeg.flv" width="300" height="225" allowfullscreen="true"></embed>

gets transformed to:

<embed width="300" height="225" allowfullscreen="true" flashvars="&amp;image=/picserver/s/orig/public/video/water_balloon_copy_24.mpeg.flv0000.jpg&amp;file=/picserver/s/video/public/water_balloon_copy_24.mpeg.flv" menu="true" loop="true" play="true" src="../../videoplayer/mediaplayer.swf?0.07093275174449953" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash"></embed>

Tested with both Windows and OS X Firefox 2. Windows Safari 3 does not seem to have this problem.

Change History

comment:1 Changed 6 years ago by w.olchawa

  • Keywords Confirmed added

Confirmed in IE, IE7 and FF2.

comment:2 Changed 5 years ago by arczi

  • Milestone set to CKEditor 3.x

In 3.0 RC is replaced with:

<embed allowfullscreen="true" flashvars="&amp;image=/picserver/s/orig/public/video/water_balloon_copy_24.mpeg.flv0000.jpg&amp;file=/picserver/s/video/public/water_balloon_copy_24.mpeg.flv" height="225" loop="true" menu="true" play="true" pluginspage="http://www.macromedia.com/go/getflashplayer" src="http://delfi.laborint.com/r/videoplayer/mediaplayer.swf?0.07093275174449953" type="application/x-shockwave-flash" width="300"></embed>

comment:3 Changed 5 years ago by garry.yao

  • Status changed from new to closed
  • Resolution set to invalid

It works fine in V3, because:

  1. The attributes is sorted in alphabetic;
  2. The '&' escaped as '&amp;' could be optionally configured by forceSimpleAmpersand.

comment:4 Changed 5 years ago by fredck

  • Status changed from closed to reopened
  • Resolution invalid deleted

comment:5 Changed 5 years ago by fredck

  • Status changed from reopened to closed
  • Resolution set to fixed
  • Milestone changed from CKEditor 3.x to CKEditor 3.0
Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy