Opened 12 years ago

Closed 7 years ago

#1836 closed New Feature (wontfix)

Restrict New Floating Dialogs to stay within client area

Reported by: Paul Moers Owned by:
Priority: Normal Milestone:
Component: UI : Dialogs Version: FCKeditor 2.6 Beta
Keywords: Cc:

Description

2008-02-09 > when toying with the New Floating Dialogs (which I really love ;)) I thought that that it might feel more robust when they would be restricting to stay within the client area when dragged.

E.g. http://www.fckeditor.net/nightly/fckeditor/_samples/default.html > click button that opens dialog > drag dialog to far right > scrollbars appear or drag to any window border > the dialog can be dragged outside the window.

Maybe this could be made configurable.

Change History (4)

comment:1 Changed 12 years ago by Frederico Caldeira Knabben

Keywords: Confirmed added; New Floating Dialogs restrict drag movement within client area removed

comment:2 Changed 12 years ago by Alfonso Martínez de Lizarrondo

Component: GeneralUI : Dialogs
Version: FCKeditor 2.6 Beta

#2012 has been marked as dup

comment:3 Changed 12 years ago by Frederico Caldeira Knabben

Milestone: FCKeditor 2.7

We should not make it configurable though.

comment:4 Changed 7 years ago by Jakub Ś

Resolution: wontfix
Status: confirmedclosed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy