Opened 10 years ago

Closed 10 years ago

#1837 closed Bug (fixed)

Can not input <references /> - button missing

Reported by: chenxing Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version: FCKeditor 2.6.3
Keywords: fixed Cc: cxcxcxcx@…, oradke@…

Description

Although there is a button to insert <ref>s, but there is no button to insert <references/> , I have to turn to "Wikitext" to add this tag. I guess it's a bug.

Attachments (6)

1837.patch (1.9 KB) - added by Artur Formella 10 years ago.
1837_2.patch (4.1 KB) - added by Artur Formella 10 years ago.
1837_3.patch (2.2 KB) - added by Artur Formella 10 years ago.
1837_4.patch (2.2 KB) - added by Artur Formella 10 years ago.
1837_5.patch (4.2 KB) - added by Artur Formella 10 years ago.
1837_6.patch (5.4 KB) - added by Artur Formella 10 years ago.

Download all attachments as: .zip

Change History (19)

comment:1 Changed 10 years ago by Wojciech Olchawa

Keywords: Confirmed added

comment:2 Changed 10 years ago by Oliver C. Radke

Cc: oradke@… added
Summary: Can not input <references />Can not input <references /> - button missing
Version: FCKeditor 2.6.3

I saw that there's already code in the source and there's even an icon for the button. I hope it's easy to fix, since it is vital for the whole references concept to work.

comment:3 Changed 10 years ago by Artur Formella

Keywords: Review? added

Changed 10 years ago by Artur Formella

Attachment: 1837.patch added

comment:4 Changed 10 years ago by Wiktor Walc

Keywords: Review- added; Review? removed

Actually we need two things:

  • as the original post says, we need a button that adds <references/> tag
  • ref and references buttons should be added automatically to the FCKeditor toolbar only when there is an extension that defines those two tags (Cite for example)

so this patch is simply invalid.

Changed 10 years ago by Artur Formella

Attachment: 1837_2.patch added

comment:5 Changed 10 years ago by Artur Formella

Keywords: Review? added; Review- removed

comment:6 Changed 10 years ago by Wiktor Walc

Keywords: Review- added; Review? removed

Review-: there are syntax errors in fckplugin.js

Changed 10 years ago by Artur Formella

Attachment: 1837_3.patch added

comment:7 Changed 10 years ago by Artur Formella

Keywords: Review? added; Review- removed

Changed 10 years ago by Artur Formella

Attachment: 1837_4.patch added

comment:8 Changed 10 years ago by Wiktor Walc

Keywords: Review- added; Review? removed

Looks fine, but: two files from 1837_2.patch are missing + when moving mouse over references button it is not highlighted. References tag is inserted correctly.

Changed 10 years ago by Artur Formella

Attachment: 1837_5.patch added

comment:9 Changed 10 years ago by Artur Formella

Keywords: Review? added; Review- removed

comment:10 Changed 10 years ago by Wiktor Walc

Keywords: Review- added; Review? removed

When testing on MW13 / FF2 javascript errors occur.

Changed 10 years ago by Artur Formella

Attachment: 1837_6.patch added

comment:11 Changed 10 years ago by Artur Formella

Keywords: Review? added; Review- removed

comment:12 Changed 10 years ago by Wiktor Walc

Keywords: Review+ added; Review? removed

comment:13 Changed 10 years ago by Artur Formella

Keywords: fixed added; Confirmed Review+ removed
Resolution: fixed
Status: newclosed

Fixed with [2468]

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy