Opened 10 years ago

Closed 10 years ago

#1856 closed Bug (invalid)

Reference tags don't work

Reported by: Robbie62 Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version: FCKeditor 2.5
Keywords: Cc:

Description

The <ref>, </ref> and <reference/> tags are no longer recognized in the MediaWiki+FCKeditor. I have a site hosted by wiki-site.com. I can't get <ref> tags to work on my site or on wiki-site.com's sandbox. It doesn't matter if you are in the FCKeditor mode or the "old" wikitext mode. If either mode, if you type <ref>, it changes it to .&lt;/ref&gt;.

To reproduce, just copy in the following text to the sandbox at wiki-site.com: <ref>Reference text</ref> References <references/>

I set the priority to "high" because I believe references to be a very essential function of Wikis.

Thanks for your help in resolving this. Steve

Change History (3)

comment:1 Changed 10 years ago by Wojciech Olchawa

Keywords: Confirmed added
Priority: HighNormal

Confirmed in MediawWiki 1.11. Works with the 1.10 version.

comment:2 Changed 10 years ago by Alexander Knapstein

I found out that this is not a problem of FCKeditor, but of MediaWiki itself since version 1.11. Even if I deactivate FCKeditor and undone the installation of FCKedit, the reference tags don't work any more.. But we are lucky, there is a solution.

To use references you need the Cite extension for now. Look here: http://www.mediawiki.org/wiki/Project:Support_desk#.28RESOLVED.29_Can.C2.B4t_find_the_template_for_footnotes.3F

I installed the Extension Cite (http://www.mediawiki.org/wiki/Extension:Cite/Cite.php) without any customization and now reference-tags work perfectly.

Hopefully this will help you. Best regards, Alex

comment:3 Changed 10 years ago by Wiktor Walc

Keywords: Confirmed removed
Resolution: invalid
Status: newclosed

As aknapstein wrote, you need to install Cite extension to use references.

I can't reproduce it, so I'm closing it as invalid. Feel free to reopen this ticket.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy