Opened 10 years ago

Closed 9 years ago

#1857 closed Bug (worksforme)

IE: <br> added in regular text after pasting.

Reported by: Robbie62 Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version: FCKeditor 2.5
Keywords: Pending WorksForMe Cc:

Description

If you type a sentence in the MediaWiki+FCKeditor and put two spaces (as I have done for over 30 years), it renders the first space as "&nbsp;". OR If you copy a sentence and put one space after the period before copying another, it changes that space to a non-breaking space and adds a <br>.

Example, in the sandbox of wiki-site.com... 1) Copy the sentence at the bottom that starts, "Please note that all contributions to Wiki-site may be edited..." into the page in the FCKeditor mode. 2) Add a space after this sentence and then paste the sentence again. 3) Add a space again and copy the sentence a third time.

Upon the first conversion, each space you typed is converted to a non-breaking space AND two returns are added after the first non-breaking space.

After the second conversion, an additional <br> is added before the second sentence.

I've had massive problems with all these non-breaking spaces and breaks added to standard text and list text but the problems do not reproduce consistently in the sandbox. Is it possible to change FCKeditor so that it no longer adds non-breaking spaces and breaks?

Thanks again for your help. Steve

Change History (8)

comment:1 Changed 10 years ago by Wojciech Olchawa

Keywords: Pending WorksForMe added

Hi!

The &nbsp; inserted in places were there are two spaces is a expected behavior. Otherwise it would be impossible to make two spaces in a row. So unfortunately you will have to cope with this kind of behavior.

If it is for the <br> placed in the text I tried to reproduce your bug but I was unsuccessful. As you said it is very tricky to reproduce it. I know you have written a step by step instruction but the bug didn't occur to me, so could you please be so kind and try to write another instruction with the exact steps you are taking. I hope it won't be a problem. Also could you write what browser are you using.

Thanks!

comment:2 in reply to:  1 Changed 10 years ago by Robbie62

Replying to w.olchawa:

Hi!

The &nbsp; inserted in places were there are two spaces is a expected behavior. Otherwise it would be impossible to make two spaces in a row. So unfortunately you will have to cope with this kind of behavior.

I didn't notice this before but using the sandbox at Wikipedia seems to indicate that straight Mediawiki without FCKeditor simply deletes one space if you type two. This is a cleaner solution. Is it possible that these non-breaking spaces are somehow triggering <br> breaks - even sometimes in the middle of sentences?

If it is for the <br> placed in the text I tried to reproduce your bug but I was unsuccessful. As you said it is very tricky to reproduce it. I know you have written a step by step instruction but the bug didn't occur to me, so could you please be so kind and try to write another instruction with the exact steps you are taking. I hope it won't be a problem. Also could you write what browser are you using.

Thanks!

I'm using IE7. Here are the steps and this works for me every time (unlike the other occurences I FREQUENTLY have in my website).

  1. Go to wiki-site.com
  2. Enter the WYSIWYG sandbox.
  3. Stay in WYSIWYG mode and highlight the text below that says "Please note that all contributions to Wiki-site may be edited...don't submit it here." Highlight the text including the period after "here" but not beyond.
  4. Paste this text.
  5. Type one space.
  6. Paste the text again.
  7. Type one space.
  8. Paste the text a third time.
  9. Type one space and hit enter (insert return).
  10. Click on the Wikitext button to view this in Wiki markup. (You'll see that it has inserted two returns between the 1st and 2nd sentences.)
  11. Click on this button again to return to WYSIWYG.
  12. Click on this button a third time and you will see that there is now a <br> tag in front of the second sentence.

Thanks again for your help though I think I will revert my Wiki back to the editor without FCKeditor until all of these bugs can be worked out.

comment:3 Changed 10 years ago by Wojciech Olchawa

Keywords: Confimed IE added; Pending WorksForMe removed
Summary: Unwanted &nbsp; and <br> added in regular text.IE: <br> added in regular text after pasting.

Hi!

Thanks for the great description. Now I can definitively confirm this bug.

Confirmed in IE

comment:4 Changed 10 years ago by Wojciech Olchawa

Keywords: Confirmed added; Confimed removed

comment:5 Changed 10 years ago by Julia

I'm interested too. (If this bug really corresponds to my problem, I will give details too as soon as possible)!

comment:6 Changed 10 years ago by Jonathan Campbell

Any updates on this bug? I am also encountering this problem.

comment:7 Changed 10 years ago by Wiktor Walc

Keywords: Pending WorksForMe added; Confirmed IE removed

Can anyone confirm that this bug still exists in the latest version of FCKeditor extension? It seems to be fixed.

I'm having problems with reproducing it.

comment:8 Changed 9 years ago by Frederico Caldeira Knabben

Resolution: worksforme
Status: newclosed

Expired.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy