Opened 10 years ago

Closed 6 years ago

#1883 closed New Feature (invalid)

Manage interlanguage links through FCKeditor

Reported by: Evan Prodromou Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version:
Keywords: Cc:

Description

For MediaWiki, you can define certain kinds of interwiki links that won't show up in the page content. They instead get put on the "other languages" menu (by default). This is for links to translations of the article on another related wiki.

The code for an interlanguage link is identical to an interwiki link. The only way to tell one from the other is that a) the interlanguage link has "iw_local = 1" on its interwiki table row, and b) the prefix of the interlanguage link is a key in the language names array (see languages/Names.php). A common example might be, on the page "Dog", "[[fr:chien]]" to make an interlanguage link to the French version of the page.

It would be great to be able to add, delete, and edit interlanguage links using the FCKeditor plugin.

Change History (3)

comment:1 Changed 10 years ago by Wojciech Olchawa

Keywords: Confirmed added

comment:2 Changed 10 years ago by Wojciech Olchawa

#1543 and #1882 has been marked as DUP.

comment:3 Changed 6 years ago by Jakub Ś

Resolution: invalid
Status: confirmedclosed

Since FCKeditor is no longer supported and was replaced with CKEditor, active development of the MediaWiki extension and support for it are also finished.

I’m closing this ticket as it is no longer valid.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy