Opened 10 years ago

Closed 9 years ago

#1543 closed Bug (fixed)

FCKEditor breaks Interwiki links

Reported by: david basulto Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version: SVN (FCKeditor) - Retired
Keywords: Confirmed Cc:

Description

When using InterWiki links, FCKEditor translates them to regular wiki links, breaking its functionability.

IE:

[w:Barcelona] gets translated to a link to http://en.wikipedia.org/wiki/Barcelona when using InterWiki capabilities.

FCKEditor converts that syntax into:

[[W:Barcelona|w:Barcelona]]

converting it into a regular Wiki link to page W:Barcelona

Change History (15)

comment:1 Changed 10 years ago by Frederico Caldeira Knabben

Component: GeneralProject : MediaWiki+FCKeditor

comment:2 Changed 10 years ago by cvh

I use 2 wiki for 2 languages and make use of interwiki links: fr:Main-Page and nl:Main-Page When I read a page with interwiki link, the source contains the link and it works well. But when I edit the page with FCKeditor the link disappears from de textarea and if I save the link is irremediably lost is ther a pragmatic solution to avoid this ? I use MediaWiki: 1.11.0 and fck/mw-extension (0.7.4) 2007 (07-02-2007)

comment:3 Changed 10 years ago by Wojciech Olchawa

Resolution: duplicate
Status: newclosed

I'm setting this ticket as DUP of #1883 because we have more information about this issue in that ticket.

comment:4 Changed 10 years ago by Evan Prodromou

This is not a dupe of 1883! This is about interwiki links, which are rendered in the page as regular <a> links. That's different from interlanguage links, which are rendered outside the main text of the page (in a special menu on the left-hand sidebar, in the default skin).

For example, on the Vinismo article about Italian wine, http://vinismo.com/en/Italy , there's an interwiki link to the Wikipedia article on Italian wine. It looks like "Italian wine". It renders in the text of the article.

There's also an interlanguage link to the French Vinismo article about Italian wine at http://vinismo.com/fr/Italie . The code looks like "[[fr:Italie]]", and it renders on the left sidebar. Different MW skins put interlanguage links in different pages, but they almost always end up outside the main flow of text.

So: there are two different problems here; it's probably a bad idea to try to combine them.

comment:5 Changed 10 years ago by Wojciech Olchawa

Resolution: duplicate
Status: closedreopened

Sorry Evan. I misunderstood the reporter. I'm reopening this ticket.

Thanks for help.

comment:6 Changed 10 years ago by Eric Bloch

I'm using a recent mediawiki+fckeeditor integration and what I see is that the editor rewrites my interwiki links. Suppose I have [[foo:bar]] mapped to http://foo.com/bar. The editor will take foo.bar? wikitext and rewrite it to

the actual expanded URL foo:bar. This is workable, but a pain when I need to modify the mapping from foo:bar to http://foo2.com/bar]

I suspect this is an error in the integration and no fckeditor per se, but I don't know.

comment:7 Changed 10 years ago by Eric Bloch

Gasp. The editor ate some of my formatting. Let me try again.

I'm using a recent mediawiki+fckeeditor integration and what I see is that the editor rewrites my interwiki links. Suppose I have [[foo:bar]] mapped to http://foo.com/bar The editor will take [[foo.bar]] wikitext and rewrite it to the actual expanded URL [http://foo2.com/bar foo:bar]. This is workable, but a pain when I need to modify the mapping from foo:bar to

I suspect this is an error in the integration and no fckeditor per se, but I don't know.

comment:8 Changed 10 years ago by Wojciech Olchawa

#2030 has been marked as DUP

comment:9 Changed 10 years ago by Eric Bloch

Fwiw, the description is #2030 describes a similar but slightly different rewriting, if that makes a difference.

comment:10 Changed 10 years ago by Wojciech Olchawa

Keywords: Confirmed added
Version: SVN

Confirmed using IE and FF2 at MW 1.12 and SVN version of FCKeditor

comment:11 Changed 10 years ago by Wiktor Walc

Resolution: fixed
Status: reopenedclosed

Fixed with [1852].

comment:12 Changed 10 years ago by Eric Bloch

Resolution: fixed
Status: closedreopened

I just took last nights fckeditor build and plopped it into my mediawiki and I'm still seeing the issue I reported in #2030

[[foo:bar]] is being re-written as foo:bar

comment:13 Changed 10 years ago by Eric Bloch

Ach I forget to do the write formatting here agin.

[[foo:bar]]

is being rewritten as

[http://foo/bar  foo:bar]

comment:14 Changed 10 years ago by Wiktor Walc

Fixed bug with overwriting interwiki link description (introduced with [1859]): [1930].

EricBloch: I can't reproduce this issue in our Sandbox: http://mediawiki.fckeditor.net/index.php/1543 (remember to clear your browsers cache).

comment:15 Changed 9 years ago by Wiktor Walc

Resolution: fixed
Status: reopenedclosed

Marking as fixed because the original issue has been fixed, please create another ticket to report issue with [[foo:bar]] if you still are able to repoduce it (I can't).

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy