Opened 10 years ago

Closed 10 years ago

#1886 closed New Feature (fixed)

Adobe AIR compatibility

Reported by: Frederico Caldeira Knabben Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: FCKeditor 2.6
Component: General Version:
Keywords: Confirmed Review+ Cc:

Description

The editor must run inside the Adobe AIR platform.

Attachments (2)

1886.patch (15.7 KB) - added by Frederico Caldeira Knabben 10 years ago.
1886_2.patch (17.1 KB) - added by Frederico Caldeira Knabben 10 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 10 years ago by Frederico Caldeira Knabben

Status: newassigned

Changed 10 years ago by Frederico Caldeira Knabben

Attachment: 1886.patch added

comment:2 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review? added

I've attached a patch which bring AIR compatibility to FCKeditor. There may still be some unknown things to be considered, but it seems to be enough for the 2.6 Beta 1, and the compatibility announcement. Actually it seems we have almost full compatibility. Thanks to the Adobe AIR team for pointing us the issues to be fixed. It was nice to see that there were just a few things to be worked to achieve it.

The only known weak point is the API registration code (see TODO in the code). But we can live with it for now, as it impacts the editor usage in some very restricted cases.

I've proposed the integration code in a mostly unobtrusive way. Everything is places in the editor/js/fckadobeair.js file. Some few integration points have been introduced in the core code, but without affecting anything in the core itself. Being AIR a desktop solution, loading an extra file doesn't bring any performance impact.

A sample application can be found in the _samples/adobeair folder. It is enough to have the AIR SDK installed at "C:\Adobe AIR SDK" and execute _samples/adobeair/run.bat to see it in action.

Changed 10 years ago by Frederico Caldeira Knabben

Attachment: 1886_2.patch added

comment:3 Changed 10 years ago by Frederico Caldeira Knabben

Updated the patch, including a package batch file to make it easy to create an .air file for the sample. Some binary stuff has been already included in the trunk with [1592].

comment:4 Changed 10 years ago by Kevin Ashworth

Under the Link dialog, when you select the Protocol pulldown, AIR crashes. Error:

The element type "other" must be terminated by the matching end-tag "</other>".

In other words, the final option is "<other>" and that's invalid XHTML. No problems are caused in Safari, Firefox, etc. Firefox source shows gt and lt entities being used, don't know why that kills AIR.

Since it's meant to generate href's that don't specify a protocol, and thus use the current one (http://, typically), maybe a different word would be better in addition to removing the brackets.

comment:5 Changed 10 years ago by Alfonso Martínez de Lizarrondo

The bug in the Link dialog is also present in the table properties, and any other page with such a select including a &lt;title&gt; caption.

Just this simple testcase is enough and should be send to the AIR developers:

	<select name="test">
		<option value="1">&lt;click me&gt;</option>
	</select>

(of course, put it in an HTML page inside an AIR app)

comment:6 Changed 10 years ago by Alfonso Martínez de Lizarrondo

This bug is due to the old webkit version that they are using:

Dragging a link makes the whole application window go blank.

Insert a link, or to easily repeat the test, edit the sample file and change the initial value to

oFCKeditor.Value	= '<p><a href="http://www.fckeditor.net">FCKeditor<\/a> is in the <strong>AIR<\/strong>!<\/p>' ;

Now, just try to drag the link, when you drop it at the end of the line for example the editor vanishes away

The same problem also happens inserting and dragging an image.

It doesn't seem possible to drag simple texts at all.

comment:7 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Keywords: Review+ added; Review? removed

According to the IRC, those bugs will be fixed in the final AIR version, so we can check this in order to get better testing.

comment:8 Changed 10 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: assignedclosed

Adobe AIR compatibility introduced with [1596].

Note that the sample application descriptor file contains the namespace (xmlns) of the final AIR release. To run it with AIR Beta 3, it must be changed to "http://ns.adobe.com/air/application/1.0.M6".

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy