Opened 11 years ago

Closed 11 years ago

#1887 closed Bug (duplicate)

Paragraph styles not selectable

Reported by: Andrew Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.5
Keywords: Discussion Cc:

Description

If you have one or more styles set in fckstyles.xml which use the p element, in the editor every <p> shows as having the styles selected, even if they are not. You are therefore unable to set the p style on a paragraph.

Example styles in fckstyles.xml:

<Style name="Intro Text" element="p">

<Attribute name="class" value="IntroText" />

</Style>

<Style name="Sub-Head" element="p">

<Attribute name="class" value="SubHead" />

</Style>

Attachments (1)

fck_styles.jpg (23.8 KB) - added by Andrew 11 years ago.
Screenshot of style dropdown showing styles selected

Download all attachments as: .zip

Change History (3)

Changed 11 years ago by Andrew

Attachment: fck_styles.jpg added

Screenshot of style dropdown showing styles selected

comment:1 Changed 11 years ago by Wojciech Olchawa

Keywords: Discussion added

Hi!

When the FCKConfig.EnterMode function is set to 'p' and you will apply your customs styles which use the <p> element, you will find that your styles are both selected. In some way it makes sense because a new entered text is inside the <p> tags, so both of the styles apply to it.

If you set the FCKConfig.EnterMode function to 'div' or 'br' the problem won't occur at all and you will be able to select your custom styles.

It's hard to say what should be the expected behavior. If you begin writing in a paragraph by default which style should be chosen. The first one frm the list or the second.

I will mark this ticket as Discussion.

Thanks for investigating.

comment:2 Changed 11 years ago by Wojciech Olchawa

Resolution: duplicate
Status: newclosed

DUP of #1503

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy