Opened 10 years ago

Closed 10 years ago

#1900 closed Bug (fixed)

[IE] List content crashes when using preview or saving a page

Reported by: Greg Miller Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version: FCKeditor 2.5
Keywords: Confirmed IE Cc:

Description

My apologies for cross-posting this from the FCKeditor support site; this site appears to be the more appropriate location for this, however.

We first discovered this issue locally in IE7 (FF seems unaffected), but this issue was confirmed in IE7 in the MediaWiki+FCKEditor sandbox. http://mediawiki.fckeditor.net/index.php/Sandbox

The problem is FCKeditor is mis-behaving when dealing with extra white spaces in list items. For example, if you take the following wikitext list

* a bullet list
* anchors
* links

and put three blank spaces immediately before and after the word "bullet" in the first list item then click 'Show preview' or view the Wikitext and go back to the WYSIWYG display. The list gets mangled to look like the following (again in wikitext).

*
* a   
* bullet    list
* anchors
* links

Sometimes I also get a Javascript error:

Line: 88
Error: 'null' is null or not an object

From the following file -- (I had to fat-finger this in, so it may not be completely accurate) extensions/FCKeditor/fckeditor/editor/js/fckeditorcode_ie.js

This is the offending line of code (line 88):

var FCKEvents=function(A){this.Owner=A;this._RegisteredEvents={};};FCKEvents.prototype.AttachEvent=function(A,B){var C;if (!(C=this._RegisteredEvents[A])) this._RegisteredEvents[A]=[B];else C.push(B);};FCKEvents.prototype.FireEvent=function(A,B){var C=true;var D=this._RegisteredEvents[A];if (D){for (var i=0;i<D.length;i++){try{C=(D[i](this.Owner,B)&&C);}catch(e){if (e.number!=-2146823277) throw e;}}};return C;};

Change History (12)

comment:1 Changed 10 years ago by Wojciech Olchawa

Keywords: Pending WorksForMe added

Hi!

I was truing to reproduce your bug following your instruction however I was unsuccessful .

I wrote a comment on the Sanbox page regarding what step I have taken (Developers Test). I will also post them here because someone might delete it:

Steps i have taken:

# Insert the following code:

* a bullet list
* anchors
* links

# Insert three whitespaces right before and right after the word bullet

# Show preview

# Go to wikitext and see the result

The result was:

* a bullet list 
* anchors 
* links

as it suppose to be.

I'm using IE7 7.0.6000.16609.

So please let me know if I have been mistaken following the steps of your instruction.

Thanks

comment:2 Changed 10 years ago by Wojciech Olchawa

Component: GeneralProject : MediaWiki+FCKeditor

comment:3 Changed 10 years ago by Wojciech Olchawa

Version: FCKeditor 2.5

#1901 has been marked as DUP

comment:4 in reply to:  description Changed 10 years ago by Greg Miller

I'm using IE 7.0.5730.11 WinXP Prof SP2 We are finding the error on every system with IE on it; with our clients and here at our company, and on home systems as well.

What I find very confusing is that in your test, you are not getting the &nbsp; character shoved into the text. That is clearly what is happening here. I have no idea why it should be behaving completely differently for you than it is for us.

comment:5 Changed 10 years ago by Greg Miller

Out of curiosity, are you using Windows Vista?

comment:6 Changed 10 years ago by Wojciech Olchawa

Keywords: Confirmed IE added; Pending WorksForMe removed

Ok I found why I haven't been able to reproduce it.

Steps to reproduce:

# Insert the following code:

* a bullet list
* anchors
* links

# Insert three whitespaces right before and right after the word bullet !!!in normal view, not in Wikitext!!'''

# Show preview

# Go to wikitext and see the result

The result was:

*
* a&nbsp;&nbsp;&nbsp;
* bullet&nbsp;&nbsp; &nbsp;list
* anchors
* links

So the result is the same, just took one step less while reproducing. I think we had a similar bug tough.

Thanks for investigating.

P.S. Yes I use Vista as well :)

comment:7 Changed 10 years ago by Wojciech Olchawa

Also Confirmed in IE 6.0

comment:8 Changed 10 years ago by Greg Miller

Another example of the problem, but more prevalent (but still IE related) than earlier documented. Again, this behavior was verified in the sandbox.

Start with the following wikitext

* Keep formatting adjustments to a minimum.
* Use headings ("Heading 1," "Heading 2," etc.) in a logical, structured manner. You can check the structure of a page by looking at the "Contents."
* Primarily use the default formatting, bold, italic, underline: color should be used sparingly and, ideally, for the purpose of discussion or to indicate a note that requires attention

In the first bullet, add the letter 'a' in front of the word 'adjustments' and click on 'Show Preview' and the following wikitext results:

* 
* Keep formatting a
* adjustments to a minimum.
* Use headings ("Heading 1," "Heading 2," etc.) in a logical, structured manner. You can check the structure of a page by looking at the "Contents."
* Primarily use the default formatting, bold, italic, underline: color should be used sparingly and, ideally, for the purpose of discussion or to indicate a note that requires attention

Once this behavior starts it seems to affect putting letter and the beginning or end of words, cause the list to degenerate even further.

I'd recommend making this bug a high-priority; as it stands now our project is now on hold until we can figure out how to work around this behavior.

comment:9 Changed 10 years ago by Wojciech Olchawa

Summary: List item mangling due to extra whitespaces[IE] List content crashes when using preview

#1922 has been marked as DUP

comment:10 in reply to:  9 Changed 10 years ago by Greg Miller

I'd ammend that to say "when using preview or saving the page"

comment:11 Changed 10 years ago by Wojciech Olchawa

Summary: [IE] List content crashes when using preview[IE] List content crashes when using preview or saving a page

I'd ammend that to say "when using preview or saving the page"

Thanks for the tip :)

comment:12 Changed 10 years ago by Wiktor Walc

Resolution: fixed
Status: newclosed

This issue has been probably fixed along with ticket #1003 - I can't reproduce it anymore.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy