Opened 12 years ago

Closed 12 years ago

#1922 closed Bug (duplicate)

Editor mangling text output in IE

Reported by: Greg Miller Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version: FCKeditor 2.5
Keywords: Cc:

Description

Having a critical issue with the way Mediawiki+FCKeditor is behaving for editing text in IE (FF is unaffected). Suprious linefeeds introduced during the transformation of editor text to text output during the 'Save' or 'Preview' operations are ruining our ability to use the editor for even simple/basic text editing in a production environment. Complicating the issue is that this problem appears to happen intermittently, but once it does occur initially it keeps repeating. I have tested this in the sandbox ( http://mediawiki.fckeditor.net/index.php/Sandbox ) to verify it is a current issue.

This is an example of what the wikitext looks like before attempting to edit it.

* Keep formatting adjustments to a '''''minimum'''''.
* Use headings ("Heading 1," "Heading 2," etc.) in a logical, structured manner. You can check the structure of a page by looking at the "Contents."
* Primarily use the default formatting, bold, italic, underline: color should be used sparingly and, ideally, for the purpose of discussion or to indicate a note that requires attention.

Typing in the letter 'a' before 'adjustments' in the first list item and clicking on 'Save page' or 'Show preview' will mangle the output (see effect below) or changing the first letter in other list items will also cause a problem. If the problem does not manifest itself on the first try, keep altering it -- adding letters to words and changing the first letter of words, and it will eventually occur and once it does it is impossible to avoid.

* 
* Keep formatting a
* adjustments to a '''''minimum'''''.
* Use headings ("Heading 1," "Heading 2," etc.) in a logical, structured manner. You can check the structure of a page by looking at the "Contents."
* Primarily use the default formatting, bold, italic, underline: color should be used sparingly and, ideally, for the purpose of discussion or to indicate a note that requires attention.

Change History (1)

comment:1 Changed 12 years ago by Wojciech Olchawa

Priority: HighNormal
Resolution: duplicate
Status: newclosed

DUP of #1900

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy