Opened 10 years ago

Closed 10 years ago

#1904 closed Bug (duplicate)

DIV not assigning class

Reported by: Jef Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.5.1
Keywords: Confirmed Cc:

Description

version 2.5.1 Build 17566

We have styles set to our div styles in a CSS. DIV is also the default normal. When trying to add a selected style to a div where the code is <div> some text here </div> the div will not apply. When it is <div class=> some text here </div> the style applies great.

If you need to see a reprodcution of this or server config files please let me know. I have attached some config files.

my email is my username.

Attachments (2)

fckconfig.js (10.5 KB) - added by Jef 10 years ago.
Config File
fckstyles.xml (1.4 KB) - added by Jef 10 years ago.
Styles XML

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by Jef

Attachment: fckconfig.js added

Config File

Changed 10 years ago by Jef

Attachment: fckstyles.xml added

Styles XML

comment:1 Changed 10 years ago by Wojciech Olchawa

Keywords: Confirmed added
Resolution: duplicate
Status: newclosed

Hi!

It seems to me that you have a similar problem to #1503 and #1887. As I reviewed your config file and your xml style file I've noticed that you have assigned four styles with a <div>. Without the class name it is impossible to apply your custom div style and it is a expected behavior because if the <div> itself (without the class name) would apply to your custom styles, it would have to apply to all of them (all with the div declaration). So possibly you are experiencing the same problem as in #1887.

This problem has been fixed in the latest SVN version.

I'm marking this as a DUP of #1503.

Feel free to reopen this ticket if it isn't the same problem that you are experiencing.

Thanks for investigation.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy