Opened 11 years ago

Closed 11 years ago

#1954 closed Bug (worksforme)

Opera: extra paragraph space when loading

Reported by: Frederico Caldeira Knabben Owned by:
Priority: Must have (possibly next milestone) Milestone: Opera Compatibility
Component: General Version: SVN (FCKeditor) - Retired
Keywords: Confirmed Opera Cc: Hallvord R. M. Steen (Opera Software)

Description

When opening sample01.html, an extra paragraph space is automatically added at the top of the loaded contents.

Confirmed with Opera build 9812.

Change History (3)

comment:1 Changed 11 years ago by Frederico Caldeira Knabben

Analysing the DOM, I could verify that there are no nodes been added before the loaded <p>. So, my impression is that Opera is expanding that space because it is having the text input selection before the opening <p>:

|<p>This is some <strong>sample text<\/strong>. You are using <a href="http://www.fckeditor.net/">FCKeditor<\/a>.<\/p>

Where "|" is the caret position.

This is only my impression though... only Hallvord is able to confirm that this is true.

To note that, it doesn't happen when switching back and forth to the source view.

comment:2 Changed 11 years ago by Frederico Caldeira Knabben

Summary: OperaOpera: extra paragraph space when loading

comment:3 Changed 11 years ago by Hallvord R. M. Steen (Opera Software)

Resolution: worksforme
Status: newclosed

This does not happen when I load http://www.fckeditor.net/nightly/browsers_test.html in (internal) build 9825. I can reproduce in build 9816, so I assume it has been fixed already - setting status to worksforme.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy