Opened 12 years ago

Closed 6 years ago

#1972 closed Bug (fixed)

Active font not selected in pull-down on focus or highlight when content pasted from Word

Reported by: Thomas Messier Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.5 Beta
Keywords: Cc:

Description

Take some content from Word and format it with a font (for example Comic Sans MS) and paste it into FCKEditor. When you click somewhere in the text or highlight a portion of text, the Font pull-down menu doesn't show the font for the text you highlighted or focused on.

Change History (5)

comment:1 Changed 12 years ago by Thomas Messier

Forgot to say this happens in both IE 7 and Firefox 2.

comment:2 Changed 12 years ago by Wojciech Olchawa

Keywords: Confirmed added

Confirmed using SVN version and beta version in IE and FF2.

comment:3 Changed 12 years ago by Frederico Caldeira Knabben

Milestone: FCKeditor 2.7
Version: FCKeditor 2.6 BetaFCKeditor 2.5 Beta

It works for me with single word font names, like Arial, but not for composed names, like "Comic Sans MS" or "Courier New". It happens because the font names are coming under quotes in those cases.

comment:4 Changed 11 years ago by Julia

News from that post do interest me.

comment:5 Changed 6 years ago by Jakub Ś

Resolution: fixed
Status: confirmedclosed

Currently if font is defined in font dropdown and element with same font is clicked, dropdown gets updated.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy