Opened 11 years ago

Closed 11 years ago

#1971 closed Bug (fixed)

[IE] Linking an Image causes a serious JavaScript error in IE

Reported by: Chris Sgaraglino Owned by:
Priority: Normal Milestone: FCKeditor 2.6
Component: UI : Dialogs Version: FCKeditor 2.6 Beta
Keywords: Confirmed IE Cc:

Description (last modified by Wojciech Olchawa)

Ok I have searched and did not find an entry for this. I have tested this on Windows XP with IE7 and Firefox and it fails in IE7 but works in Firefox. I was not able to test this in the Nightly version and images browsing is disabled.

How to repeat:

  1. Load your Demo Tool
  1. Delete all text
  1. Insert the Eagle Image
  1. Add the text "This is an Eagle" under the image (this is just so the image is no longer selected)
  1. Exit the Image Dialog
  1. Click ONCE on the image (producing the image handles)
  1. Click the Insert Link
  1. Add any URL (www.fckeditor.net)
  1. Click OK.

This adds the link to the code, but the Link Dialog does not close; locking the surfer from being able to do anything else. The only way out here is to hit F5 to refresh the page, causing you to loose all your changes.

At this point there is no way to close the Dialog Box!

Attachments (3)

winXPMC-IE7.jpg (146.5 KB) - added by Chris Sgaraglino 11 years ago.
Windows XPMC & IE7
winVista-IE7.jpg (114.2 KB) - added by Chris Sgaraglino 11 years ago.
Windows Vista & IE7
win2K-IE6.jpg (145.4 KB) - added by Chris Sgaraglino 11 years ago.
Windows 2000 & IE6

Download all attachments as: .zip

Change History (9)

comment:1 Changed 11 years ago by Wojciech Olchawa

Keywords: Pending WorksForMe added

Hi!

Following you steps both in 2.6 beta and the current nightly I was unable to reproduce your bug. However I'm using Vista so the behavior can be different.

In my case the image is inserted in the background of the Image Dialog window and flashes several times. Afterwards the image is inserted and the Image Dialog window is closed.

comment:2 Changed 11 years ago by Wojciech Olchawa

Component: GeneralUI : Dialogs

Changed 11 years ago by Chris Sgaraglino

Attachment: winXPMC-IE7.jpg added

Windows XPMC & IE7

Changed 11 years ago by Chris Sgaraglino

Attachment: winVista-IE7.jpg added

Windows Vista & IE7

Changed 11 years ago by Chris Sgaraglino

Attachment: win2K-IE6.jpg added

Windows 2000 & IE6

comment:3 Changed 11 years ago by Chris Sgaraglino

I have attached three (3) screen shots from three (3) different servers/computers. All three (3) failed.

The key when selecting the image is to just click on the image once. If you drag to select it works fine. But if the image is NOT selected and you click once (giving you the resizing handles) and then try to add or update a link it fails.

Also this does not fail with using FireFox.

comment:4 Changed 11 years ago by Wojciech Olchawa

Description: modified (diff)
Keywords: Confirmed IE added; Pending WorksForMe removed
Summary: Linking an Image causes a serious JavaScript error in IE[IE] Linking an Image causes a serious JavaScript error in IE

Thanks for the images. I misunderstood your step by step instruction.

Confirmed in IE using latest SVN and 2.6 beta. I've changed the description of "How to reproduce" a little bit. Hope it's OK.

comment:5 Changed 11 years ago by Wojciech Olchawa

#2004 has been marked as DUP

comment:6 Changed 11 years ago by Frederico Caldeira Knabben

Milestone: FCKeditor 2.6
Resolution: fixed
Status: newclosed

This one has been fixed with [1688] for #1934.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy