Opened 11 years ago

Closed 11 years ago

#2004 closed Bug (duplicate)

Create URL on image

Reported by: Andrey Efimov Owned by:
Priority: Normal Milestone:
Component: UI : Dialogs Version:
Keywords: Pending Cc:

Description

When the image in editor not text-selected, the url creation dialog fails on ok or cancel buttons and can not be closed.

I've created a stub, currently but not a fix. if fckdialog.html:

EnsureSelection : function() { if ( FCKDialog.SelectionData )

{ if (FCKDialog.SelectionData.htmlText != undefined) efimov's stub

FCKDialog.SelectionData.select() ;

}

},

Change History (3)

comment:1 Changed 11 years ago by Wojciech Olchawa

Keywords: Pending added; url image removed

Hi!

I'm not able to reproduce your bug. Could you provide more information about the bug possibly containing a step by step instruction? Also could provide information about the version of FCKeditor that you are using?

Thanks in advance.

comment:2 in reply to:  1 Changed 11 years ago by Andrey Efimov

ok. Open Editor. Insert an Image. Select it with one mouse click, for example (the little square appear at the corners). Select create link tool. Dialog opens. Input some url: http://www.fckeditor.net, for example. Press ok. Dialog not closed, javascript errors are in the status. Using IE 6 and 7. Using version 2.6 or your demo version on site.

Replying to w.olchawa:

Hi!

I'm not able to reproduce your bug. Could you provide more information about the bug possibly containing a step by step instruction? Also could provide information about the version of FCKeditor that you are using?

Thanks in advance.

comment:3 Changed 11 years ago by Wojciech Olchawa

Resolution: duplicate
Status: newclosed

Hi.

Thanks for the instruction. It turns out it is a DUP of #1971. All information about the bug will be provided there.

Thanks for investigating.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy