Opened 10 years ago

Closed 10 years ago

#1989 closed Bug (fixed)

xhtml source formatting works only in IE

Reported by: Branko Jevtic Owned by: Martin Kou
Priority: Must have (possibly next milestone) Milestone: FCKeditor 2.6
Component: Core : Output Data Version: FCKeditor 2.6 Beta
Keywords: Confirmed Firefox Review+ Cc:

Description

In fckeditor 2.6 beta if you look at the source in firefox (on windows and mac os) and safari it is HTML not XHTML, but if you take a look at the same editor in Internet Explorer it is as it supposed to be XHTML (<br />, <img ... />...). It is not only happening on my implementation of fckeditor it is also present in your demo page, and included samples. I'm using php implementation.

Attachments (1)

1989.patch (2.8 KB) - added by Martin Kou 10 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 10 years ago by Frederico Caldeira Knabben

Component: GeneralCore : Output Data
Keywords: Confirmed Firefox added
Milestone: FCKeditor 2.6
Priority: NormalHigh
Version: FCKeditor 2.6 Beta

Confirmed with FF.

comment:2 Changed 10 years ago by Martin Kou

Owner: set to Martin Kou
Status: newassigned

comment:3 Changed 10 years ago by Martin Kou

Both this ticket and #1981 are caused by the change to fckxhtml_gecko.js in [1192].

comment:4 Changed 10 years ago by Martin Kou

Also, the changes in fcktools_gecko.js contribute to the bug.

Changed 10 years ago by Martin Kou

Attachment: 1989.patch added

comment:5 Changed 10 years ago by Martin Kou

Keywords: Review? added

comment:6 Changed 10 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

Nice trick Martin! I was sure this bug was coming from that change.

This one should also fix #1955 and #1981, as you have already noted.

comment:7 Changed 10 years ago by Martin Kou

Resolution: fixed
Status: assignedclosed

Fixed with [1691].

Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy