Opened 12 years ago

Closed 8 years ago

#1993 closed Bug (worksforme)

Trying to select multiple paragraphs and set font properties to match the first one selected.

Reported by: Mark Butler Owned by:
Priority: Normal Milestone:
Component: Core : Styles Version: FCKeditor 2.5.1
Keywords: Cc:

Description

In the situation where you have 3 paragraphs of text each assigned a different font size. When trying to change all of them to a different size here is what happens...

In earlier versions if you highlight paragraphs with different font size the font size pull down would clear to empty selection.

In (current 2.5x & what ever is on your demo page) if you highlight paragraphs with different font sizes the drop down stays selected at what ever the first paragraph highlighted was set to. Thus you cannot change the subsiquent paragraphs because the tool does not read the drop down as being changed.

Change History (4)

comment:1 Changed 12 years ago by Mark Butler

In the situation where you have 3 paragraphs of text each assigned a different font size. When trying to change all of them at the same time to match the first...

In earlier versions if you highlight paragraphs with different font size the font size pull down would clear to empty selection. Allowing you to change all 3 at once to what ever the first paragraph was set to.

In (current 2.5x & what ever is on your demo page) if you highlight paragraphs with different font sizes the drop down stays selected at what ever the first paragraph highlighted was set to. Thus you cannot change the subsiquent paragraphs because the tool does not read the drop down as being changed. You must select the lower paragraphs seperatly or change all 3 to something diffent than what the first is set to and then change all 3 back to what the first one was.

comment:2 Changed 12 years ago by Wojciech Olchawa

Keywords: Confirmed added
Version: FCKeditor 2.5.1

Confirmed using 2.5.1 , 2.6 beat and the latest SVN on IE na FF2.

comment:3 Changed 11 years ago by Julia

I'm interesting in these problems of style!

comment:4 Changed 8 years ago by Krzysztof Studnik

Component: GeneralCore : Styles
Resolution: worksforme
Status: confirmedclosed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy