Opened 10 years ago

Closed 9 years ago

#2032 closed Task (fixed)

Create samples for Flash and "Old HTML" configurations

Reported by: Frederico Caldeira Knabben Owned by: Martin Kou
Priority: Normal Milestone: FCKeditor 2.6.3
Component: General Version:
Keywords: Confirmed Review+ Cc:

Description

FCKeditor is by default set to work with XHTML 1.0 Transitional.

Today we have sample14.html, which is a nice demonstration on how to configure FCKeditor for XHTML 1.1. We should create other two samples that match some important usage cases: Flash and Old HTML.

Flash accepts a limited number of tags. A reference for it can be found here: http://kb.adobe.com/selfservice/viewContent.do?externalId=tn_14808

The old HTML sample should be called "Legacy Tags". It should be configured to work with <b>, <i> and <font> tags.

Change History (12)

comment:1 Changed 9 years ago by Martin Kou

Owner: set to Martin Kou
Status: newassigned

comment:2 Changed 9 years ago by Martin Kou

Keywords: Review? added

Since the feature demands that binary .swf files be added, and .diff files can't express binary files, I'm opening a new branch for this feature:

https://svn.fckeditor.net/FCKeditor/branches/features/new_samples

The new samples can be found under _samples/html/sample15.html and _samples/html/sample16.html. Both should be working now.

comment:3 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed

sample15.html looks good. I would just remove the 'Strong Emphasis' and 'Emphasis' styles from the combo because those have nothing to do with Bold and Italic.

sample16.html instead still needs some more work. It should give a move WYSIWYG experience:

  • The paragraph spacing is quite different between the editor and the Flash text (so space here actually. This could be easily solved by setting margin:0px in the editor area styles.
  • There are several problems with the space added in the output source for formatting. It can be checked when moving to source and back to wysiwyg. It results on char spaces in front of paragraphs and line spaces between list items. It can be solved by setting both FormatSource and FormatOutput to false.
  • Just like sample15, the 'Strong Emphasis' and 'Emphasis' styles are improperly proposed. The Style combo can be totally removed from the toolbar.
  • Maybe it is better to present the sample by having the editor in the left and the flash file in the right. It avoids having to scroll to see the results, and having a small toolbar helps in this sense.
  • The text at the sample description should end with "...with Flash.". "Flash Objects" is not a known term to make reference to it.
  • Flash gives a lot of power to end developers. The plain text example is quite boring... looks like a normal iframe. We should have some graphics and effects there. I can help in this sense.

comment:4 Changed 9 years ago by Frederico Caldeira Knabben

I've committed a new Flash file for sample16 with [2218]. This is not to say that it is an amazing new thing... it's just not that plain. I hope Martin will like it.

comment:5 Changed 9 years ago by Martin Kou

Keywords: Review? added; Review- removed

I've fixed all the issues above and merged all the changes in trunk to the new_samples branch.

comment:6 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Review- added; Review? removed

The new layout was not working under my screen resolution (1024x768). I've made some changes to it, using the good and old table layout to have flexible width there.

I've also fixed some other things and committed it with [2235].

There is still one problem though, which I hope is not related to my last commit. It is not working with IE.

comment:7 Changed 9 years ago by Frederico Caldeira Knabben

Btw... I was talking about the new Flash sample, of course.

comment:8 Changed 9 years ago by Martin Kou

It works for me on both IE6 and IE7. Did you load the sample from local harddisk? It seems Flash's ExternalInterface.addCallback() doesn't work when it's loaded from local harddisk.

comment:9 Changed 9 years ago by Martin Kou

Keywords: Review? added; Review- removed

Found the cause of the IE7 bug in the Flash sample - Flash objects with external interfaces cannot be loaded inside <form> tags in IE7 or else the external interface would not work. I've removed the <form> tag and it's now working.

comment:10 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

I've done further changes to the branch with [2264]. The html samples folder was becoming too disordered, so I've created the "assets" folder leaving only the main sample##.html files in the folder root.

Also, there were still some issues in the implementation:

  • Fixed syntax errors in the config file of sample15.
  • On sample16, the about dialog box was under the flash.
  • The margins of <ul> and <ol> elements where actually removing the bullets in IE.
  • The new samples where not in the samples list.

I've fixed all those issues with that changeset too. If it looks ok to you Martin, go ahead moving it to the trunk at this point.

comment:11 Changed 9 years ago by Frederico Caldeira Knabben

Sorry, the samples have been added to the samples list with [2266].

comment:12 Changed 9 years ago by Martin Kou

Resolution: fixed
Status: assignedclosed

Fixed with [2273].

Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy