Opened 11 years ago

Closed 6 years ago

#2050 closed Bug (fixed)

Line breaks after bold lines are missing the nbsp

Reported by: Ian Danforth Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.6 Beta
Keywords: Discussion Cc:

Description

Steps to reproduce

  1. Type a line into the 2.6 beta
  1. Bold that line
  1. Hit return from the end of that line
  1. View source

Expected result: <p><b>&nbsp;</b></p>

Observed result: <p><b></b></p>

Consequences: The line you intended to add after the bolded line will not appear when the page is saved and viewed.

Note: This occurs with other style tags as well.

Standard ticket submission mantra: I searched but did not find, if I erred, the fault is mine.

Change History (3)

comment:1 Changed 11 years ago by Wojciech Olchawa

Keywords: Discussion added; return nbsp removed
Version: FCKeditor 2.6 Beta

Confirmed in FF2 in 2.6 beta. IE shows a different behaviour. The reproduction result is:

<p>&nbsp;</p>
<p>&nbsp;</p>

so no <b> tag is added at all.

The same thing as above happens when trying to reproduce using the SVN version both in IE and FF2.

As "&nbsp" is added in the current SVN release the reported bug isn't valid in this sense. However it rises the question - should the "<b>" tag be added to an empty line, so the result would be:

<p><b>&nbsp;</b></p>

For me it owuld be the expected behaviour however other users may think differently so I'm opening a discussion due to this issue.

comment:2 Changed 8 years ago by Krzysztof Studnik

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

comment:3 Changed 6 years ago by Piotrek Koszuliński

Resolution: fixed
Status: newclosed

This issue expired.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy