Opened 11 years ago

Closed 11 years ago

#2062 closed Bug (invalid)

[FF] Merge Down and Merge Right doesn't work

Reported by: Wojciech Olchawa Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.6 Beta
Keywords: Confirmed Firefox Cc:

Description

I've encountered a bug while reproducing bug #2055 and checking the FF behaviour.

It seems it's impossible to merge cells down and right.

Steps to reproduce:

  1. Open demo page www.fckeditor.net/demo using FF
  1. Insert a table 2x3

  1. Go into the the top left cell

  1. Try to choose merge.

Not only options : Merge Down and Merge Right aren't present but the Merge Cells option is disabled as well.

This bug doesn't occur in IE6 and IE7.

Browser: Firefox 2.0.0.12

OS: Windows XP

FCKeditor versions affected: 2.6beta and the current SVN

Change History (1)

comment:1 Changed 11 years ago by Martin Kou

Resolution: invalid
Status: newclosed

This is actually a feature not a bug. ;)

Since Firefox allows the user to selection multiple table cells, the merge cells feature was designed to be easier to use in Firefox. To merge cells in Firefox, drag your mouse across a few cells, right click, and choose Cells -> Merge cells (it should be enabled whenever you have a rectangular selection). The table cells will be merged. No dialog box or stepwise merge needed.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy