Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#2063 closed Bug (fixed)

Problem on uploading file

Reported by: cyim Owned by: Alfonso Martínez de Lizarrondo
Priority: Normal Milestone: FCKeditor 2.6.1
Component: Server : ASP Version: FCKeditor 2.5.1
Keywords: Confirmed Review+ Cc: e.l-hostis@…

Description

I try to upload a file, but I have this error : ADODB.Stream erreur '800a0bbc' Impossible d'écrire dans le fichier

In English, it means "Impossible to write in the file". Here, the file path generated by fck :
NAS-PROD\wwwsites-data$\demo-modules.cyim.com\upload\file/test.doc

The problem is due to a concatenation of IIS server path and file path. IIS path is like that
cylab\sites\ File path is like that : /file/myfile.doc

I have updated the file "class_upload.asp" to correct my problem : Function SaveAs, I add this line : sFileName = replace(sFileName, "/", "\")

I think i'm not the first guy to use IIS and FCK. So, why i have this problem ?

Attachments (2)

ConfigSiteWeb.png (20.4 KB) - added by cyim 9 years ago.
2063.patch (2.9 KB) - added by Alfonso Martínez de Lizarrondo 9 years ago.
Proposed patch

Download all attachments as: .zip

Change History (8)

Changed 9 years ago by cyim

Attachment: ConfigSiteWeb.png added

comment:1 Changed 9 years ago by Wojciech Olchawa

Keywords: Pending WorksForMe added; IIS Upload removed

I'm not a IIS expert, however I have encountered similar problems when trying to upload a file. In my case (using the asp connector) the mistake was that I didn't create a proper directory for the user files and IIS was blocking the creation of a new directory when the File Browser where ran. Firstly I would check

ConfigUserFilesPath = '/your directory here/' 

(line 35 in config.asp) and see what path has been set there.

So this looks like a privileges problem to me however since I don't know IIS much I could be mistaken. Please let us know about the results.

Thanks

comment:2 Changed 9 years ago by Alfonso Martínez de Lizarrondo

Keywords: Confirmed added; Pending WorksForMe removed
Owner: set to Alfonso Martínez de Lizarrondo
Status: newassigned

I can confirm that this problem happens with using a network path for the files. I'm gonna attach a patch that fixes this and at least another problem related to network paths.

Changed 9 years ago by Alfonso Martínez de Lizarrondo

Attachment: 2063.patch added

Proposed patch

comment:3 Changed 9 years ago by Alfonso Martínez de Lizarrondo

Keywords: Review? added

The if (sParent = "") then exit sub line in the patch avoids an out of memory error (the function calls itself recursively with an empty string).

comment:4 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

comment:5 Changed 9 years ago by Alfonso Martínez de Lizarrondo

Milestone: FCKeditor 2.6.1
Resolution: fixed
Status: assignedclosed

Fixed with [2037]

comment:6 Changed 9 years ago by cyim

Thanks a lot :)

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy