Opened 12 years ago

Closed 11 years ago

#2075 closed Bug (fixed)

Link conversion bug FCKEditor extension 2.5.1 MediaWiki 1.12

Reported by: Stefan van Gastel Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version: FCKeditor 2.5.1
Keywords: Fixed Cc:

Description

Make a text in WYSIWYG mode. Select a word. Click the link button. Select the page to link to. Click 'OK'

--So far it works great.

Now, switch to WikiText mode. Switch back to WYSIWYG mode...

--The link is converted to bold text.

Attachments (1)

2075.patch (1.5 KB) - added by Artur Formella 11 years ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 12 years ago by Wojciech Olchawa

Keywords: Pending WorksForMe added; link WYSIWYG WikiText removed
Priority: HighNormal
Version: FCKeditor 2.5.1

I've tried to reproduce your bug using both IE and FF2 and I was unable to reproduce your bug. I've used the latest SVN version of FCKeditor and everything worked as epected.

Try to upgrade to the latest SVN from http://svn.fckeditor.net/MediaWiki/trunk/ . Clear the cache in your browser and let us know if the bug still occurs.

Thanks in advance.

comment:2 in reply to:  1 Changed 12 years ago by Stefan van Gastel

Replying to w.olchawa:

I've tried to reproduce your bug using both IE and FF2 and I was unable to reproduce your bug. I've used the latest SVN version of FCKeditor and everything worked as epected.

Try to upgrade to the latest SVN from http://svn.fckeditor.net/MediaWiki/trunk/ . Clear the cache in your browser and let us know if the bug still occurs.

Thanks in advance.

Confirmed, works for me too. Strange it doesn't work with the 2.5.1 packaged version. So checking out from the trunk works!

comment:3 Changed 12 years ago by Wojciech Olchawa

Keywords: Pending WorksForMe removed
Resolution: worksforme
Status: newclosed

comment:4 Changed 12 years ago by mark

Resolution: worksforme
Status: closedreopened

This bug does in fact still exist. When you edit fckeditor_config.js to enable the ['TextColor','BGColor'] buttons the bug will occur. If you leave that disabled the bug does not occur.

comment:5 Changed 12 years ago by mark

Note that this bug also occurs if ['JustifyLeft','JustifyCenter','JustifyRight','JustifyFull'] is enabled in fckeditor_config.js.

comment:6 Changed 12 years ago by Wojciech Olchawa

Keywords: Pending WorksForMe added

I've set up the config file and the bug still didn't occur to me when using the latest SVN version of FCKeditor. I've tried both of the configurations and still nothing.

Could you please upgrade to the latest SVN version and check if the bug still occurs? Thanks

comment:7 Changed 11 years ago by beam36

Keywords: Pending WorksForMe removed
Priority: NormalHigh
Version: FCKeditor 2.5.1FCKeditor 2.6.2

I also face this same problem. I use mediawiki 1.12. I've tried checkout FCKeditor extension from svn and download the latest version of FCKeditor (which is 2.6.2) but it still doesn't work

comment:8 Changed 11 years ago by Frederico Caldeira Knabben

Priority: HighNormal

comment:9 Changed 11 years ago by Alfonso Martínez de Lizarrondo

Version: FCKeditor 2.6.2FCKeditor 2.5.1

The version field should mark the first version where the problem is found. Of course that it's also present in later versions, or the bug would have been marked as fixed.

comment:10 Changed 11 years ago by Wiktor Walc

Keywords: Confirmed added

Confirmed at least in one special situation: when linking to the same page I was editing.

To reproduce, edit Main_Page and add a link:

[[Main_Page|Main_Page]]

it is translated by parser into

<strong class="selflink">Main_Page</strong>

which is later changed into bold by FCKeditor.

Changed 11 years ago by Artur Formella

Attachment: 2075.patch added

comment:11 Changed 11 years ago by Artur Formella

Keywords: Review? added

comment:12 Changed 11 years ago by Wiktor Walc

Keywords: Review+ added; Review? removed

comment:13 Changed 11 years ago by Artur Formella

Keywords: Fixed added; Confirmed Review+ removed
Resolution: fixed
Status: reopenedclosed

Fixed with [2430]

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy