Opened 12 years ago

Closed 11 years ago

#2086 closed Bug (duplicate)

[FF3 ]scrolling behaviour not correct

Reported by: voracity Owned by:
Priority: Normal Milestone:
Component: UI : Enter Key Version: FCKeditor 2.6 RC
Keywords: Confirmed Firefox Cc:

Description

When hitting enter (and creating a new paragraph), the entire page will scroll back up in the Firefox 3 beta. Apparently, the behaviour of scrollIntoView has changed to match IE, so that scrollIntoView(true) should be used (rather than scrollIntoView(false), which is used now).

I found this related ticket:

http://dev.fckeditor.net/changeset/1126

The relevant bug in bugzilla:

https://bugzilla.mozilla.org/show_bug.cgi?id=426698

Change History (5)

comment:1 Changed 12 years ago by Wojciech Olchawa

Keywords: Pending WorksForMe added
Version: FCKeditor 2.6 RC

I was unable to reproduce your bug on our demo page using FCKeditor 2.6RC. Could you please provide more information on how to reproduce the bug, possibly with a step by step instruction.

Thanks.

comment:2 Changed 12 years ago by Paul Hoepfner-Homme

I'm experiencing the same problem. I've tested it using the official FCKeditor demo page by following this procedure:

  1. Download and install Firefox 3 Beta 5 for Mac OS X or Windows (I haven't tested Linux).
  2. In FF3b5, navigate to http://www.fckeditor.net/demo.
  3. Resize the browser window so that a vertical scrollbar appears.
  4. Scroll to the bottom of the browser window.
  5. In the FCKeditor, hit the enter key.
  6. The browser window scrolls to the top.

This doesn't happen in Firefox 2 or IE.

I'm using FCKeditor on a new website I'm developing and Firefox 3 has been my main browser for a while, and since the editor always appears low on the page, this annoying behaviour is finally starting to try my patience... :)

Hope this helps you reproduce it!

comment:3 Changed 12 years ago by Paul Hoepfner-Homme

Changing scrollIntoView(false) to scrollIntoView(true) for FF3 still doesn't produce the correct behaviour. If true is used, when you hit enter the viewport scrolls so that the cursor is at the top of the browser window, whereas with false it scrolls so that the cursor was at the bottom of the browser window. It doesn't just leave it alone if the cursor is already positioned within the viewport.

What I've found works best for the time being - though it's still not perfect - is to just restrict the use of scrollIntoView() to Gecko versions 1.8 and earlier (using a FCKBrowserInfo.IsGecko10 check instead of just FCKBrowserInfo.IsGecko) in editor/_source/classes/fckenterkey.js and editor/_source/internals/fck.js.

This means that in FF3, when you hit enter at the bottom of the editor when the editor is partially hidden by the bottom of the browser window, the viewport won't automatically scroll down to reveal the new position of the cursor, which is what I guess scrollIntoView() was intended to solve.

I still prefer this behaviour in FF3 over the current behaviour where the whole browser window gets scrolled up every time you hit enter, no matter where the cursor is in the editor.

comment:4 Changed 12 years ago by Wojciech Olchawa

Keywords: Confirmed Firefox added; Pending WorksForMe removed
Summary: scrolling behaviour no longer correct in Firefox 3[FF3 ]scrolling behaviour not correct

Confirmed using FCKeditor 2.6 on FF3 beta 5

comment:5 Changed 11 years ago by Frederico Caldeira Knabben

Resolution: duplicate
Status: newclosed

Unfortunately this ticket come to my eyes only now. It is supposed to be fixed with the patch for #2279, for I'm closing this one as DUP, just to avoid duplications.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy