Opened 9 years ago

Closed 9 years ago

#2279 closed Bug (fixed)

Firefox RC3 Scrollbar position problem

Reported by: Dave Owned by: Frederico Caldeira Knabben
Priority: Must have (possibly next milestone) Milestone: FCKeditor 2.6.2
Component: UI : Enter Key Version:
Keywords: Firefox3 Confirmed Review+ Cc:

Description

OS: Windows XP sp2 Browser: Firefox RC3 Builds Tested: 2.6.0, 2.6.1, Nightly Build 6/15/08

Steps to reproduce:

1) Open fckEditor sample running at: http://www.fckeditor.net/nightly/fckeditor/_samples/default.html

2) Press the "Maximize editor size" on the toolbar

3) Press any letter followed by the enter key

4) Repeat step 3 40 times

5) Scroll to the middle of the document and set the cursor at the end of a paragraph.

6) press the enter key

BUG: Scrollbar moves up and paragraph is reposition at bottom of page.

From my understanding "ScrollIntoView" has been changed in Firefox 3 to match IE, I'll bet that is where the problem lies.

Will test will Firefox 3 final when it is released 6/17/08

Attachments (1)

2279.patch (1.9 KB) - added by Frederico Caldeira Knabben 9 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 9 years ago by Frederico Caldeira Knabben

Component: GeneralUI : Enter Key
Keywords: Firefox3 Confirmed added; Scrollbar Firefox 3 removed
Milestone: FCKeditor 2.6.2
Priority: NormalHigh

comment:2 Changed 9 years ago by Frederico Caldeira Knabben

Owner: set to Frederico Caldeira Knabben
Status: newassigned

Changed 9 years ago by Frederico Caldeira Knabben

Attachment: 2279.patch added

comment:3 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Review? added

The provided patch simply uses the same method we were using with Safari until now (for #1462). It also fixes #2276.

It's a pity that this thing came to our eyes right after the 2.6.1... let's wait for the 2.6.2.

comment:4 Changed 9 years ago by Frederico Caldeira Knabben

#2286 has been marked as DUP.

comment:5 Changed 9 years ago by Martin Kou

Keywords: Review+ added; Review? removed

comment:6 Changed 9 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: assignedclosed

Fixed with [2096].

comment:7 Changed 9 years ago by gboissiere

Resolution: fixed
Status: closedreopened

Unfortunately, it appears that this issue is not fully fixed in 2.6.2.

With FCKConfig.EnterMode = 'br' ; The problem is still there.

Alternatively with the default config (i.e. FCKConfig.ShiftEnterMode = 'br') when pressing Shift + Enter, the problem is there also.

comment:8 Changed 9 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: reopenedclosed

@gboissiere, I've just opened a dedicated ticket to it: #2319.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy