Opened 10 years ago

Closed 10 years ago

#2278 closed Bug (fixed)

FCKeditor fails on 1.13alpha

Reported by: Jack Phoenix Owned by:
Priority: Must have (possibly next milestone) Milestone:
Component: Project : MediaWiki+FCKeditor Version: SVN (FCKeditor) - Retired
Keywords: Cc:

Description

FCKeditor breaks MediaWikis running the newest trunk version. Such a wiki will display errors such as this:

Warning: require_once(/includes/ParserOptions.php) [function.require-once]: failed to open stream: No such file or directory in /extensions/FCKeditor/FCKeditor.php on line 29

caused by the explicit require_once() calls in FCKeditor.php, as MW's directory structure was reorganized just a few moments ago. The solution is to remove these require_once() calls from FCKeditor.php as they're not needed, MediaWiki's autoloader does the work in 1.13alpha automatically. I did this with my local devel copy and after that FCKeditor worked nicely and nothing was seemingly broken.

Change History (1)

comment:1 Changed 10 years ago by Wiktor Walc

Resolution: fixed
Status: newclosed

Fixed with [2074] & [2075].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy