Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#2137 closed Bug (worksforme)

string convert error "<span class="

Reported by: smilodon Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version: SVN (FCKeditor) - Retired
Keywords: fixed Cc:

Description

If I place a template string:

 [http://xmswid/bugzilla/show_bug.cgi?id={{{id}}} Bug{{{id}}}]

it will be converted to

 [http://hello/bugzilla/show_bug.cgi?id=<span class= {{{id}}}"&gt;Bug{{{id}}}]

after preview or save.

tested in http://mediawiki.fckeditor.net/index.php?title=Sandbox

Thanks!

Attachments (1)

2137.patch (1.2 KB) - added by Wiktor Walc 12 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 12 years ago by Wojciech Olchawa

Keywords: Confirmed added

Confirmed on both IE and FF2. Also happens when switching back and forth from wikitext to wysiwyg view.

Changed 12 years ago by Wiktor Walc

Attachment: 2137.patch added

comment:2 Changed 12 years ago by Wiktor Walc

Keywords: HasPatch added

I'm attaching a patch proposal. The main idea is that arguments shouldn't be processed like templates, but simply left as it is.

I'm just wondering whether leaving everything between {{{ and }}} will not break something else? That's why I'm not commitiing it yet.

If possible, test this patch and let us know if it works.

comment:3 Changed 12 years ago by smilodon

I just test this patch,and find it is ok now!

Thanks!

And will it be merge to new release?

comment:4 Changed 11 years ago by jeremysolt

This problem doesn't seem to be limited to templates, e.g., if I embed magic words into links this happens too.

{{SITENAME}}:About? will get converted the same way. The patch does not seem to fix that.

comment:5 Changed 11 years ago by Wiktor Walc

Keywords: Confirmed HasPatch removed
Resolution: worksforme
Status: newclosed

Can't reproduce it in the latest release.

comment:6 Changed 11 years ago by Artur Formella

Keywords: fixed added

Fixed with ticket #2482

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy