Opened 12 years ago

Closed 7 years ago

#2151 closed Bug (wontfix)

Contextmenu mispositioned when editor in div with scrollbar

Reported by: Christian Zagrodnick Owned by:
Priority: Normal Milestone:
Component: General Version: SVN (FCKeditor) - Retired
Keywords: Firefox HasPatch Cc:

Description

When the editor is in a div with a scrollbar the contextmenu and style menu is misalinged.

There was once ticket #135 which seem to cover the same so this might be a new bug introduced in 2.6.

I'll attach a patch which fixes this for firefox.

Attachments (1)

scrolloffset.patch (1.4 KB) - added by Christian Zagrodnick 12 years ago.
Fix contextmenu position

Download all attachments as: .zip

Change History (5)

Changed 12 years ago by Christian Zagrodnick

Attachment: scrolloffset.patch added

Fix contextmenu position

comment:1 Changed 12 years ago by Wojciech Olchawa

Keywords: Confirmed Firefox HasPatch added

Confirmed using the latest SVN in FF2. Works fine in IE.

comment:2 Changed 12 years ago by Wojciech Olchawa

The attached patch failed my test. The context menu was displayed only in one place.

comment:3 Changed 12 years ago by Christian Zagrodnick

I probably should add a test case (haven't got time for that right now though).

Also, could you add you test case so I can check what's wrong?

comment:4 Changed 7 years ago by Jakub Ś

Resolution: wontfix
Status: confirmedclosed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy