Opened 11 years ago

Closed 8 years ago

#2158 closed Bug (wontfix)

Links cause spellerpages to go out of sync and not complete, ending with error.

Reported by: SJB Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version: FCKeditor 2.5.1
Keywords: HasPatch Cc:

Description

I have set up spellerpages on my wiki. When I attempt to use it on any page that includes any type of wiki link in this form Text? it goes out of sync, and all following words are out of sync. Then when the page is done checking, I get an error "Error: Not in dictionary" text missing. I then can't save any of the editing changes, and must cancel out.

This happens with any page containing a Category link, which is most of them.

If you scroll to find the link that breaks things, in the top spell check window, the text appears as a link is surrounded by "_fcksavedurl="Link">Text and links to something like:

"category:<input readonly class="

in the case of a Category link at the bottom of the page.

Attachments (2)

spellcheck_error.png (9.9 KB) - added by SJB 11 years ago.
screenshot of error
spellerpages-patch.patch (1.0 KB) - added by javadeveloper404 11 years ago.
tag attribute snv source patch for wordWindow.js, writeBody.

Download all attachments as: .zip

Change History (7)

Changed 11 years ago by SJB

Attachment: spellcheck_error.png added

screenshot of error

comment:1 Changed 11 years ago by SJB

I would like to update this to state, that this problem seems to occur only when Link exactly equals Text in Text?. If Text is different from Link, There seems to be no problem.

comment:2 Changed 11 years ago by Wojciech Olchawa

Keywords: Confirmed added; spellerpages links removed

Confirmed using MW 1.12 and the current FCKeditor SVN extension in Firefox and IE.

comment:3 Changed 11 years ago by SJB

The following plugin solves all of these issues for me.

http://sourceforge.net/tracker/index.php?func=detail&aid=1856428&group_id=75348&atid=737639

The base spellerpages files should probably use some changes that were made in this plugin.

comment:4 Changed 11 years ago by javadeveloper404

The changes to wordWindow.js in the referanced plugin go beyond what I needed (such as removing words not found) but the attached source patch skips over matched strings within tag attributes. I hit this with text pasted from MSWord, and tables having the x:str="..." attribute set containg the same misspelled word.

Changed 11 years ago by javadeveloper404

Attachment: spellerpages-patch.patch added

tag attribute snv source patch for wordWindow.js, writeBody.

comment:5 Changed 8 years ago by Krzysztof Studnik

Keywords: HasPatch added
Resolution: wontfix
Status: confirmedclosed

FCKEditor +MediaWiki is no longer supported.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy