Opened 11 years ago

Closed 11 years ago

#2167 closed Bug (fixed)

[IE] Foucs isn't placed on floating dialogs.

Reported by: Wojciech Olchawa Owned by: Artur Formella
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version: SVN (FCKeditor) - Retired
Keywords: Confirmed IE Review+ Cc:

Description

When you open a link dialog or a image dialog, the focus isn't placed on the dialog but remains in the editing area.

Steps to reproduce

  1. Open the Insert Link Dialog
  1. Start to type (without placing the cursor in the proper place.
  1. If you type you will see that the text appears in the editing area and the cursor is blinking on the dialog area as well.

In this situation you can't insert a link when you have highlighted a text which should be made a link because it will overwrite your selection.

Testing area

Tested using IE6 and IE7 on MediaWiki 1.12 using the latest FCKeditor SVN version. This bug doesn't occur on FF2.

Attachments (1)

2167.patch (2.5 KB) - added by Artur Formella 11 years ago.

Download all attachments as: .zip

Change History (5)

Changed 11 years ago by Artur Formella

Attachment: 2167.patch added

comment:1 Changed 11 years ago by Artur Formella

Keywords: Review? added

comment:2 Changed 11 years ago by Wiktor Walc

Keywords: Review+ added; Review? removed

comment:3 Changed 11 years ago by Frederico Caldeira Knabben

Owner: set to Artur Formella

comment:4 Changed 11 years ago by Artur Formella

Resolution: fixed
Status: newclosed

Fixed with [3190]

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy