Opened 12 years ago

Closed 8 years ago

#2166 closed Bug (worksforme)

[IE] Link isn't displayed when image is placed inside <fieldset>

Reported by: Friendly Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.6
Keywords: Confirmed IE Cc:

Description

Hi there

I was playing around with your editor and found a bug. If I use the following code: <fieldset>

<a href="/File/Meg_TechRun1.jpg">

<img src="/Image/001_Meg_TechRun_Thumb.jpg" />

</a>

</fieldset>

and right click on the image and edit the link, it moves the cursor to the first position in the source and the link in the popup is empty. This is happening in my IE7 browser, but not in my Firefox.

If you need more information, feel free to email me at friendly_781114@…

Thanks.

M

Change History (6)

comment:1 Changed 12 years ago by Wojciech Olchawa

Keywords: Confirmed IE added
Summary: Bug found with <fieldset>[IE] Link isn't displayed when image is placed inside <fieldset>
Version: FCKeditor 2.6

Confirmed on IE with FCKeditor 2.6 and the latest SVN. Works fine with FF

comment:2 Changed 11 years ago by Alfonso Martínez de Lizarrondo

Milestone: FCKeditor 2.6.4
Resolution: fixed
Status: newclosed

Works fine in SVN, I guess that it was fixed by #798

comment:3 Changed 11 years ago by Adriano Azzarone

Resolution: fixed
Status: closedreopened

Trying to insert link or see properties on a image inside <fieldset> tag. Nothing to do in IE7.. also after patching with #798 (#2375). Testing this patch, not only the bug was not fixed, but it makes impossible to see image properties of a simple image anywhere (inside or not that tag). Is the first time I try a patch here, but I'm quite sure of what I did.

On Opera (9.61) the bug is not the same. It is possible to see properties of an image in <fieldset> tag, but inserting a link on it, the image disappears..

comment:4 Changed 11 years ago by Adriano Azzarone

I'm sorry... Bug #798 = [2375] Fix

comment:5 Changed 11 years ago by Alfonso Martínez de Lizarrondo

Milestone: FCKeditor 2.6.4

comment:6 Changed 8 years ago by Krzysztof Studnik

Resolution: worksforme
Status: reopenedclosed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy