Opened 10 years ago

Closed 9 years ago

#798 closed Bug (fixed)

Image inside floating DIV looses selection with Context Menu

Reported by: cinzia62@… Owned by: Alfonso Martínez de Lizarrondo
Priority: Normal Milestone: FCKeditor 2.6.4
Component: General Version: FCKeditor 2.5
Keywords: SF Confirmed IE Review+ Cc: Frederico Caldeira Knabben

Description

If you add an image into a Div then you apply a style to the div like this <div style="float:right"><img ...> </div> if then you select the image and get the properties, it appears that all the properties are lost. But if you go to the source code you can see that they are not lost. Following the source code with debugger, I noticed that this instruction in fck_image.js

var oImage = FCK.Selection.GetSelectedElement() ;

Moved from SF:
http://sourceforge.net/tracker/index.php?func=detail&aid=1628785&group_id=75348&atid=543653

return an undefined element. I have tested it with IE6 on WinXP e win2003.

Attachments (1)

798.patch (2.9 KB) - added by Alfonso Martínez de Lizarrondo 9 years ago.
Proposed patch

Download all attachments as: .zip

Change History (11)

comment:1 Changed 10 years ago by Martin Kou

Reporter: changed from Martin Kou to cinzia62@…

comment:2 Changed 10 years ago by Martin Kou

Cc: Frederico Caldeira Knabben added

It happens only when opening the image properties dialog by using the context menu. The image toolbar button instead works correctly.


Moved from SF. Original poster: fredck

comment:3 Changed 9 years ago by Wojciech Olchawa

Keywords: Confirmed IE added
Version: SVN

FF2 - works fine

IE - image properties doesn't show using the toolbar button as well as from the context menu.

Tested on 2.5 SVN Build 18185

comment:4 Changed 9 years ago by Wojciech Olchawa

#1910 has been marked as DUP

comment:5 Changed 9 years ago by Frederico Caldeira Knabben

It looks like an IE bug. It returns "none" for document.selection.type in such cases. I'm not sure we have much to do here.

comment:6 Changed 9 years ago by Alfonso Martínez de Lizarrondo

Version: SVNFCKeditor 2.5

Note: I've opened a new ticket for the cases non related to the context menu as #2495

comment:7 Changed 9 years ago by Alfonso Martínez de Lizarrondo

Owner: set to Alfonso Martínez de Lizarrondo
Status: newassigned

The problem is caused by the FCK.Focus() call in FCK_ContextMenu_OnItemClick (fck_contextmenu.js). Disabling it makes the dialog work correctly (of course it might break other things, so some further research is needed to verify how to properly fix this)

Changed 9 years ago by Alfonso Martínez de Lizarrondo

Attachment: 798.patch added

Proposed patch

comment:8 Changed 9 years ago by Alfonso Martínez de Lizarrondo

Keywords: Review? added

The patch does remove the Focus call only for IE, due to the usage of popups it seems that it isn't necessary and the problem is fixed, but anyway the patch for #2495 is also needed here, so I've included also in the patch to make it easier to test it.

comment:9 Changed 9 years ago by Martin Kou

Keywords: Review+ added; Review? removed
Milestone: FCKeditor 2.6.4

comment:10 Changed 9 years ago by Alfonso Martínez de Lizarrondo

Resolution: fixed
Status: assignedclosed

Fixed with [2375]

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy