Opened 12 years ago

Closed 8 years ago

#2181 closed Bug (invalid)

Premature preview/save bug

Reported by: y Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version: FCKeditor 2.6.4
Keywords: Cc: gmiller@…

Description

If, on the edit page, a user clicks the "preview" or "save" buttons before the FCKeditor interface is completely loaded, internal links (such as [[User:Test]]) are not converted to wikicode but are saved as HTML tags (such as <a href="User:Test">).

Change History (4)

comment:1 Changed 12 years ago by Wojciech Olchawa

Keywords: Confirmed added
Version: SVN

Confirmed in MW 1.12 and the current FCKeditor SVN extension in IE and FF. This also applies for external links as well.

comment:2 Changed 10 years ago by Greg Miller

Cc: gmiller@… added
Priority: NormalHigh
Version: SVN (FCKeditor)FCKeditor 2.6.4

I've confirmed this as well, even with FCK V2.6.4 in MW 1.10. Don't see it with FF, only in IE. I'd recommend upping the priority on this one as it seriously mangles the content of pages. I've found that it only impact quick edits, and that if you wait several seconds (10 in our case) you can work around the issue, but given this has been around for a year now, shouldn't it be addressed?

comment:3 Changed 10 years ago by Artur Formella

Priority: HighNormal

comment:4 Changed 8 years ago by Jakub Ś

Resolution: invalid
Status: confirmedclosed

Since FCKeditor is no longer supported and was replaced with CKEditor, active development of the MediaWiki extension and support for it are also finished.

I’m closing this ticket as it is no longer valid.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy