Opened 12 years ago

Closed 11 years ago

#2187 closed Bug (invalid)

Existing image links are smashed when saving

Reported by: Brian Moore Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version: SVN (FCKeditor) - Retired
Keywords: Pending WorksForMe Cc:

Description

Adding FCKeditor to an existing wiki, if a user edits a page that has existing image links and then edits and saves with the FCKeditor, all image links on that page are broken.

Version information:

  • MediaWiki: 1.11.2
  • PHP: 5.1.6 (apache2handler)
  • MySQL: 5.0.41-community

I installed the latest nightly build and the behavior is the same.

Steps to reproduce:

  • Upload a few images without FCKeditor.
  • Create a page linking to the images in the standard way
  • On that page have links to the image files: [[Image:Imagefile.png]]
  • Edit page using FCKeditor. Make some text changes, but do not modify images. Save page and notice that no images exist.

Change History (2)

comment:1 Changed 12 years ago by Wojciech Olchawa

Keywords: Pending WorksForMe added
Version: SVN

I followed your steps and was unable to reproduce this bug using MW 1.11.2 and MW 1.12 and the current SVN extension of FCKeditor (both on IE and FF). Please let me know if I have missed anything here:

  • Uploaded two sample images (test1.jpg and test2.jpg)
  • Created a page with image links as [[Image:test1.jpg]] and [[Image:test2.jpg]]
  • Enabled FCKeditor extension
  • Edit the page and changed/written some text
  • Saved the page

Thanks in advance

comment:2 Changed 11 years ago by Frederico Caldeira Knabben

Resolution: invalid
Status: newclosed

Expired.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy