Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#2193 closed Bug (fixed)

Opera: Can't place cursor at the end of paragraphs

Reported by: Frederico Caldeira Knabben Owned by: Martin Kou
Priority: Must have (possibly next milestone) Milestone: FCKeditor 2.6.1
Component: General Version: SVN (FCKeditor) - Retired
Keywords: Confirmed Opera Review+ Cc: Hallvord R. M. Steen (Opera Software)

Description

Steps to Reproduce

  1. Load sample01.html.
  2. Delete everything.
  3. Type "This is a test" and hit ENTER.
  4. Click after "test" to move the caret to the end of that paragraph.

The caret will jump to the start of the paragraph. After that:

  1. Double click "is" and make it bold.
  2. Click the end of the paragraph again.

The caret will now jump right after "is". It seems to jump right after the last element in the paragraph, if available.

The same thing happens if you try to move the caret there with the keyboard by using both the LEFT ARROW and the RIGHT ARROW.

Confirmed with Opera build 9972.

Attachments (1)

2193.patch (1.4 KB) - added by Martin Kou 9 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 9 years ago by Hallvord R. M. Steen (Opera Software)

Still a problem in build 10037 but we'll get builds with the #2195 fix soon so I'm sort of hoping that the issues are related.. Probably needs further investigation.

comment:2 Changed 9 years ago by Hallvord R. M. Steen (Opera Software)

This is caused by a call to the MoveCursor() function.

Line 107 or so of linked script http://www.fckeditor.net/nightly/fckeditor/editor/_source/internals/fck_gecko.js contains an if clause which contains among others the following:

String(node.parentNode.contentEditable) == 'false'

This test is always true in Opera so the return statement following that if is ignored. Thus the MoveCursor function is executed to the end and places the cursor at the start of the text node you're in.

comment:3 Changed 9 years ago by Martin Kou

Owner: set to Martin Kou
Status: newassigned

Changed 9 years ago by Martin Kou

Attachment: 2193.patch added

comment:4 Changed 9 years ago by Martin Kou

Keywords: Review? added

comment:5 in reply to:  2 Changed 9 years ago by Frederico Caldeira Knabben

Replying to hallvord@opera.com:

This test is always true in Opera

Hallvord, be sure to have a ticket at your side for this one!

comment:6 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed

comment:7 Changed 9 years ago by Martin Kou

Resolution: fixed
Status: assignedclosed

Fixed with [2054].

Click here for more info about our SVN system.

comment:8 Changed 9 years ago by Frederico Caldeira Knabben

Milestone: Opera CompatibilityFCKeditor 2.6.1
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy