Opened 10 years ago

Closed 4 years ago

#2194 closed Bug (fixed)

Opera: Caret doesn't move on right click [CORE-33108]

Reported by: Frederico Caldeira Knabben Owned by:
Priority: Normal Milestone:
Component: UI : Context Menu Version: 3.4.1
Keywords: Opera Cc: Hallvord R. M. Steen (Opera Software)

Description

Steps to Reproduce

  1. Load sample01.html.
  2. Click inside the linked "FCKeditor" text to place the caret there.
  3. Right click out of the "FCKeditor" link (e.g. inside "sample text").

The link context menu options will be there because the caret was not moved to the right click point before the context menu got opened. To check it, it is enough to click in the empty space in the toolbar to hide the context menu; you will see that the caret is still in the original location.

Confirmed with Opera build 9972.

Attachments (1)

krst_21.43.28.png (35.2 KB) - added by Krzysztof Studnik 7 years ago.
Confirmed for Opera 10.61.3484, CKE 3.4.1 Nightly

Download all attachments as: .zip

Change History (7)

comment:1 Changed 10 years ago by Hallvord R. M. Steen (Opera Software)

IMO this is likely a side-effect of the button hack you use to show right-click menus in Opera. It's probably hard to fix on your side but by design on our side. (And I want oncontextmenu support, dammit :( )

Probably the long-term fix is on our side with proper oncontextmenu support. For now we can live with this open I guess..

comment:2 Changed 10 years ago by Frederico Caldeira Knabben

That's exactly what I've suspected Hallvord, and your solution seems the only way to go. We can live with it for now.

Changed 7 years ago by Krzysztof Studnik

Attachment: krst_21.43.28.png added

Confirmed for Opera 10.61.3484, CKE 3.4.1 Nightly

comment:3 Changed 7 years ago by Krzysztof Studnik

Version: SVN (FCKeditor) - Retired3.4.1 (SVN - trunk)

comment:4 Changed 7 years ago by Tobiasz Cudnik

#6234 has been marked as a DUP.

comment:5 Changed 7 years ago by Hallvord R. M. Steen (Opera Software)

Summary: Opera: Caret doesn't move on right clickOpera: Caret doesn't move on right click [CORE-33108]

Please close this bug if you like, reported on Opera's side as CORE-33108 and I think it's better fixed on our side.

comment:6 Changed 4 years ago by Piotrek Koszuliński

Resolution: fixed
Status: confirmedclosed

Fixed in Opera when it switched to Blink.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy