Opened 11 years ago

Closed 9 years ago

Last modified 9 years ago

#2202 closed Bug (worksforme)

Opera: Form elements are a bit active

Reported by: Frederico Caldeira Knabben Owned by:
Priority: Normal Milestone:
Component: UI : Dialogs Version: 3.4.1
Keywords: Opera Cc: Hallvord R. M. Steen (Opera Software)

Description

When placing form elements in the editing area, many of them are still a bit "active", even if inside an editable space. For example:

  • Checkbox: when creating a checkbox and selecting the "Selected" option, it will be checked, as expected. But, if you then click on it, the check will be "visually" removed. Click on it again and nothing happens (don't get checked again). Then, switching to the source view, you will see that the checked="checked" will still be there :/
  • Radio buttons: the same thing as the checkboxes.
  • Text field: works well, mostly. If you right click on it, you will see that the caret will start blinking inside of it and the default Opera context menu is shown. Press ESC and the FCKeditor context menu appears from behind it.
  • Textarea: the same as for the Text field.
  • Select box (1 line): get highlighted on mouse over, and no specific context menu is available.
  • Select box (2+ lines): is completely active inside the editor. You can select options and scroll it. No specific context menu too.
  • Button: not so bad, but get highlighted on mouse over.

So, form fields support is a bit unstable. Inside an editing environment, we would expect those objects to have no activity at all, not even mouse over effects, having simply the dotted blue line when selected.

Confirmed with Opera build 9972.

Change History (9)

comment:1 Changed 11 years ago by Hallvord R. M. Steen (Opera Software)

Owner: set to Hallvord R. M. Steen (Opera Software)
Status: newassigned

Seems to work as expected in build 10000.

comment:2 Changed 11 years ago by Frederico Caldeira Knabben

I can still confirm everything with Opera build 10005. No changes from the reported behavior.

comment:3 Changed 9 years ago by Krzysztof Studnik

Component: GeneralUI : Dialogs
Keywords: Confirmed removed
Owner: Hallvord R. M. Steen (Opera Software) deleted
Status: assignednew
Version: SVN (FCKeditor) - Retired3.4.1 (SVN - trunk)

Opera 10.61.3484, CKE 3.4.1 Trunk/Nightly -

Radio button issue #6238

Clicking "Select field" throws JS error:

JavaScript - http://nightly.ckeditor.com/latest/ckeditor/_samples/replacebyclass.html
Inline script compilation
Syntax error at line 201 while loading:
this.setValue( this.default || '' );
--------------------^
syntax error

comment:4 Changed 9 years ago by Krzysztof Studnik

Status: newconfirmed

comment:5 Changed 9 years ago by Hallvord R. M. Steen (Opera Software)

Regarding the "Clicking select button throws error" problem:

"Default is a reserved word and cannot be used for anything other than declaring the default clause within a switch statement."

Are other browsers more lax at enforcing reserved word restrictions? Nope, Chrome says "Uncaught SyntaxError: Unexpected token default"

As for the original problem, I still can not reproduce it.

comment:6 Changed 9 years ago by Frederico Caldeira Knabben

The select problem has been fixed with [5861].

comment:7 Changed 9 years ago by Hallvord R. M. Steen (Opera Software)

Excellent. Can you still reproduce the "form elements are a bit active" problem?

comment:8 Changed 9 years ago by Krzysztof Studnik

Resolution: worksforme
Status: confirmedclosed

I cannot reproduce JS error. It seems working now. I think I may close this issue.

comment:9 Changed 9 years ago by Krzysztof Studnik

Works also under Opera 10.61 Linux

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy