Opened 11 years ago

Closed 6 years ago

#2203 closed Bug (duplicate)

Multiple span problem

Reported by: James Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone:
Component: Core : Styles Version: FCKeditor 2.5 Beta
Keywords: HasPatch IBM Cc: monahant@…

Description

span span span span span multiple span multiple span

I select a word, apply a font face, and a font size. View the code that just added two spans, not one as I would expect. If I make any more changes to the word it will just keep on adding spans.

Attachments (4)

fckstyle.js (73.6 KB) - added by Jesse Redl 10 years ago.
attaching correct file
fckstyle.2.js (74.0 KB) - added by Jesse Redl 10 years ago.
Updated
fckstyle.3.js (47.6 KB) - added by Jesse Redl 10 years ago.
update to fckstyle.js - three functions added (_MergeChildren, _MergeFirstChild, _MergeLastChild)
fckstyles.patch (3.4 KB) - added by Jesse Redl 10 years ago.
ataching proper file..…

Download all attachments as: .zip

Change History (16)

comment:1 Changed 11 years ago by Frederico Caldeira Knabben

Component: GeneralCore : Styles
Keywords: Confirmed added
Priority: HighNormal
Version: FCKeditor 2.5 Beta

comment:2 Changed 10 years ago by Jesse Redl

Owner: set to Frederico Caldeira Knabben
Version: FCKeditor 2.5 BetaFCKeditor 2.6.3

We have implemented the missing merge style section. Tested in ie, firefox, chrome and safari.

Please consider for trunk.

Changed 10 years ago by Jesse Redl

Attachment: fckstyle.js added

attaching correct file

comment:3 Changed 10 years ago by Jesse Redl

bug fouhd..content being replaced if applying a style to a larger selection. Will fix and reattach next week.

comment:4 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Version: FCKeditor 2.6.3FCKeditor 2.5 Beta

comment:5 Changed 10 years ago by Alfonso Martínez de Lizarrondo

BTW, this patch tries to merge nodes after applying the styles, but I think that the ideal solution would be to adjust the range so it gets the correct node and then apply the styles to that node, instead of creating a node inside of it and then try to merge it back with its parent.

Changed 10 years ago by Jesse Redl

Attachment: fckstyle.2.js added

Updated

comment:6 Changed 10 years ago by James

Tried the patch out. Very promising. I noticed that it would convert a strong tag to a span tag when applying the style. But definitely headed in the right direction more like the type of content that you'd expect an editor to output.

comment:7 Changed 10 years ago by Jesse Redl

For some reason, the issue did not correctly update the orignal file I uploaded. Try the new one http://dev.fckeditor.net/attachment/ticket/2203/fckstyle.2.js

and the strong tag problem you noted should be fixed.

comment:8 Changed 10 years ago by James

Download from that link. It said it was posted 16hours ago and still has the problem with strong tags.

Changed 10 years ago by Jesse Redl

Attachment: fckstyle.3.js added

update to fckstyle.js - three functions added (_MergeChildren, _MergeFirstChild, _MergeLastChild)

Changed 10 years ago by Jesse Redl

Attachment: fckstyles.patch added

ataching proper file.....

comment:9 Changed 10 years ago by Jesse Redl

Took the time to checkout the svn repository and create a proper patch..sorry for the mess of previous comments and attached files.

comment:10 Changed 10 years ago by Alfonso Martínez de Lizarrondo

Keywords: HasPatch added

comment:11 Changed 6 years ago by Teresa Monahan

Cc: monahant@… added
Keywords: IBM added

comment:12 Changed 6 years ago by Jakub Ś

Resolution: duplicate
Status: confirmedclosed

This issue was reported for FCKeditor and we have such issue for CKEditor thus I'm closing this one as duplicate of #9295.

@tmonahan I have added your email and IBM keyword to #9295.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy