Opened 13 years ago

Closed 8 years ago

#2204 closed Bug (wontfix)

Opera: paste from right-click menu creates unformatted text even inside formatted blocks [CORE-35090]

Reported by: Hallvord R. M. Steen (Opera Software) Owned by:
Priority: Normal Milestone:
Component: General Version: SVN (FCKeditor) - Retired
Keywords: Opera Cc: Frederico Caldeira Knabben

Description

  1. Load sample01
  2. Click inside FCKEditor link to set cursor
  3. Right-click and select "paste"
  4. Paste something

Bug: the text that is pasted does not become part of the linked text, it breaks the link into two parts. Compare with behaviour in Firefox.

Attachments (1)

krst_20.43.06.png (67.9 KB) - added by Krzysztof Studnik 10 years ago.
Confirmed for Opera 10.61.3484, CKE 3.4.1 Trunk & Demo.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 13 years ago by Frederico Caldeira Knabben

Cc: Frederico Caldeira Knabben removed
Component: UI : Context MenuGeneral
Keywords: Confirmed Opera added; paste removed

Confirmed with Opera build 9972.

The same happens with the "Paste" and "Paste from Word" buttons. It strangely works well with "Paste as Plain Text".

Changed 10 years ago by Krzysztof Studnik

Attachment: krst_20.43.06.png added

Confirmed for Opera 10.61.3484, CKE 3.4.1 Trunk & Demo.

comment:2 Changed 10 years ago by Tobiasz Cudnik

Looks very similar to #5536.

comment:3 Changed 10 years ago by Hallvord R. M. Steen (Opera Software)

Cc: Frederico Caldeira Knabben added

This is still with us. I've looked at it and determined that it's a bug in Opera, now known as CORE-35090.

comment:4 Changed 10 years ago by Hallvord R. M. Steen (Opera Software)

Summary: Opera: paste from right-click menu creates unformatted text even inside formatted blocksOpera: paste from right-click menu creates unformatted text even inside formatted blocks [CORE-35090]

comment:5 Changed 10 years ago by Hallvord R. M. Steen (Opera Software)

just FYI, this was just fixed on our side. Guesstimated to land in a public release that might be called 11.20 or 11.50 - not that I really know or can promise anything about the release timeline, but it's on its way.

comment:6 Changed 8 years ago by Jakub Ś

Resolution: wontfix
Status: confirmedclosed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Works in CKEditor and latest Opera

Note: See TracTickets for help on using tickets.
© 2003 – 2020 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy