Opened 12 years ago

Closed 11 years ago

#2213 closed Bug (fixed)

Multiple Editors not fireing onload event.

Reported by: Matthew Leffler Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.6
Keywords: Pending WorksForMe Cc:

Description

When there are multiple editors on a given page sometimes the onload event is not fired. This only seems to affect FF2. The bug seems to occur after the first time the page is loaded, that is the second or subsequent refreshes. My guess would be a cache issue.

I don't know a better way to reproduce this issue than to provide a link to a test page I made that should show the issue. Link

Change History (5)

comment:1 Changed 12 years ago by Wojciech Olchawa

Keywords: Pending WorksForMe added

I've tried to reproduce your bug but I wasn't successful. Everything seems to load normally. I've refreshed the page several times with and without clearing the cache and everything worked as expected. Could you provide more detailed information about the circumstances under the bug occurs?

Thanks in advance

comment:2 Changed 12 years ago by Matthew Leffler

This morning I attempted myself to reproduce the bug by doing the following:

  1. Loaded up the test page in a new tab in Firefox 2.0.0.14. The page loaded properly and the window.onload event was fired.
  1. Came back to this page in my first tab and again opened the test page in a new tab. This time the editors load properly and I can type and open the image, flash, link popups just fine but the page doesn't stop loading until I hit ESC and force the onload event. The page is still "loading" in the other tab as I write this.

The bug is not that the editors don't load, it is that the page doesn't fire onload.

I have the following browser extensions enabled: DOM inspector, Firebug, Talkback, and Web Developer.

comment:3 Changed 12 years ago by Wojciech Olchawa

It's very tricky to reproduce this bug, I've manage to do it only once. It would be good to find a better way for reproducing this bug because otherwise it will be difficult to find the solution to the problem.

comment:4 Changed 11 years ago by Matthew Leffler

It is an interesting bug. I can reproduce it every time. I have done some testing and found some interesting things:

  1. Once I load the page the second time I never get the onload. If I clear my cache using the Clear Private Data dialog I can get the page to fire onload one time. The second time it will not fire onload. So there is something in cache that causes this issue.
  1. I can set my Drive Cache to 0Mb so that there is nothing in Drive Cache and I still have the problem after the second page load. There is something in Memory Cache that causes the bug.
  1. I have found an old forum post that someone else has the same/similar issue. Link This may be an old issue but it is uncannily similar. The only constructive comment on the thread is that someone thought it was due to multiple <form>s on a page. I don't think that is the issue.
  1. In about:config there are several settings regarding cache. I have found that if I set network.http.use-cache to false the editor will load every time. This works even if I turn disk cache back on. Is your Firefox true or false?

Let me know what you think.

comment:5 Changed 11 years ago by Matthew Leffler

Resolution: fixed
Status: newclosed

This bug seems to have fixed itself. I am resolving this ticket as fixed.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy