Opened 11 years ago

Closed 10 years ago

#2243 closed Bug (fixed)

File endings are incorrect in released packages

Reported by: Wiktor Walc Owned by: Wiktor Walc
Priority: Normal Milestone: FCKeditor 2.6.4
Component: General Version: FCKeditor 2.6.4
Keywords: Confirmed Cc: listen_div@…

Description

Reported by bitsfritz in #1667:

The *.pl and *.cgi files in FCKeditor 2.6 and nightly build still have dos style linefeeds (CRLF), so something went wrong.

Attachments (1)

2243.patch (429 bytes) - added by Wiktor Walc 11 years ago.

Download all attachments as: .zip

Change History (9)

Changed 11 years ago by Wiktor Walc

Attachment: 2243.patch added

comment:1 Changed 11 years ago by Wiktor Walc

Keywords: Review? added

It seems that the problem is located in fckreleaser.php. It contains it's own line fixing engine which isn't valid anymore.

comment:2 Changed 11 years ago by Frederico Caldeira Knabben

Keywords: Review+ added; Review? removed
Owner: set to Wiktor Walc

comment:3 Changed 11 years ago by Wiktor Walc

Resolution: fixed
Status: newclosed

Fixed with [2040].

comment:4 Changed 11 years ago by Friedrich Strohmaier

Cc: listen_div@… added
Milestone: FCKeditor 2.6.1FCKeditor 2.6.4
Resolution: fixed
Status: closedreopened
Version: FCKeditor 2.6FCKeditor 2.6.3

Hello again,

I've to reopen this one.

In the package, I got here: http://dfn.dl.sourceforge.net/sourceforge/fckeditor/FCKeditor_2.6.3.tar.gz

All files in editor/filemanager/connectors/perl/ have dos style (CRLF) linefeeds. This is a regression since 2.6.2

Gruß

comment:5 Changed 11 years ago by Wiktor Walc

Keywords: Review+ removed

Indeed it is a regression bug. [2040] has been reverted with [2245]. I suppose the "Fix invalid line breaks (must be all CRLF)." part of the code is there by mistake and should be removed again.

comment:6 Changed 11 years ago by Wiktor Walc

Resolution: fixed
Status: reopenedclosed

Fixed with [2514]. Still new fckreleaser.php must be genereted though.

comment:7 Changed 11 years ago by Friedrich Strohmaier

Resolution: fixed
Status: closedreopened
Version: FCKeditor 2.6.3FCKeditor 2.6.4

Once more ;o))

reopening, because package FCKeditor_2.6.4.tar.gz (as well FCKeditor_2.6.4.zip) contain CRLF line terminators for all files in fckeditor/editor/filemanager/connectors/perl/

including that critical (connector|upload).cgi

Aparently again something went wrong on packaging.

Friedrich

comment:8 Changed 10 years ago by Friedrich Strohmaier

Resolution: fixed
Status: reopenedclosed

As far, as I see this issue is fixed. in Package FCKeditor 2.6.4.1 from here http://downloads.sourceforge.net/sourceforge/fckeditor/FCKeditor_2.6.4.1.tar.gz?use_mirror=surfnet

Line endings are fine :o))

Thanks Guys for not running away from my nagging! :o))

Friedrich

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy