Opened 9 years ago

Closed 9 years ago

#2297 closed Bug (fixed)

The TAB key should move out of the editor if TabSpaces=0

Reported by: Frederico Caldeira Knabben Owned by: Frederico Caldeira Knabben
Priority: Normal Milestone: FCKeditor 2.6.2
Component: General Version: FCKeditor 2.6.1
Keywords: Confirmed Review+ Cc:

Description

We'll be working on the future on a complete reviewed support for the TAB key (see #979). Meanwhile, we should provide some basic features, and the ability to move out of the editor using TAB seems to be one of them.

Attachments (1)

2297.patch (1.6 KB) - added by Frederico Caldeira Knabben 9 years ago.

Download all attachments as: .zip

Change History (5)

Changed 9 years ago by Frederico Caldeira Knabben

Attachment: 2297.patch added

comment:1 Changed 9 years ago by Frederico Caldeira Knabben

Keywords: Review? added
Status: newassigned

comment:2 Changed 9 years ago by Frederico Caldeira Knabben

The provided patch simply leaves the default behavior to the browser. Safari instead automatically inserts spaces on TAB, so it is still blocking it to do that. We can live with this small incompatibility issue until #979 get fixed.

comment:3 Changed 9 years ago by Martin Kou

Keywords: Review+ added; Review? removed

comment:4 Changed 9 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: assignedclosed

Fixed with [2107].

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy