Opened 11 years ago

Closed 11 years ago

Last modified 10 years ago

#235 closed Bug (fixed)

FF: Toolbar icons are now displayed correctly on Mac OS X

Reported by: cschnell@… Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: SF Firefox Mac WorksForMe Pending Cc: giacobbej@…, liane@…

Description

The Images on Firefox for Mac OS X don't work. See attached screenshot. It was taken from http://www.fckeditor.net/demo/.

The system used is
Firefox 1.5.0.4 on Mac OS X 10.3.9 (7W98)


Moved from SF:
https://sourceforge.net/tracker/?func=detail&atid=543653&aid=1523869&group_id=75348

Attachments (1)

fckeditorImages.jpg (78.0 KB) - added by Frederico Caldeira Knabben 11 years ago.
images are not shown correctly - Moved from SF. Original author: cschnell

Download all attachments as: .zip

Change History (12)

Changed 11 years ago by Frederico Caldeira Knabben

Attachment: fckeditorImages.jpg added

images are not shown correctly - Moved from SF. Original author: cschnell

comment:1 Changed 11 years ago by Frederico Caldeira Knabben

with Firefox 1.5.0.6 on OSX 10.4.7, I can't reproduce this problem (and don't remember ever seeing this on previous versions of both)


Moved from SF. Original poster: liane

comment:2 Changed 11 years ago by Frederico Caldeira Knabben

Can you confirm it is still an issue, Christopher?


Moved from SF.

comment:3 Changed 11 years ago by Frederico Caldeira Knabben

Yes, it still is the same when visiting the Demo-Site. It looks exactly the same as in the submitted screenshot. Currently I am using FF 1.5.06 with Mac OS X 10.3.9.

I also use an old version of FCKeditor 2.0 on one of my projects and this Version looks fine on the very same setup.


Moved from SF. Original poster: cschnell

comment:4 Changed 11 years ago by Frederico Caldeira Knabben

I'll seeing the exact same problem with the 2.4 demo site under MacOS 10.3.9 and Firefox 2.0.0.2

All of the toolbar icons are corrupted just like the screenshot attached by the original submitter. The icons appear normal under Safari, so this can't be a MacOS 10.3.9 issue.

Has there been any progress on a fix?


Moved from SF. Original poster: giacobbej

comment:5 Changed 11 years ago by Frederico Caldeira Knabben

Cc: giacobbej@… liane@… added
Reporter: changed from Frederico Caldeira Knabben to cschnell@…

comment:6 Changed 11 years ago by Frederico Caldeira Knabben

Keywords: Firefox Mac WorksForMe Pending added
Summary: Images in Firefox on Mac OS XFF: Toolbar icons are now displayed correctly on Mac OS X

I'm still not able to reproduce the problem. The toolbar is perfect for me.

The thing is that, as we can see, the icons images are loaded, but an "empty image" placeholder is shown right above of them.

We use a trick to show all buttons icons. We create a transparent gif image (spacer.gif) and set its background to the real image by using styles. Of course there are good reasons to do that that way.

So, if the "spacer.gif" image is missing, you may see the empty image placeholder, but the thing is that the gif exists, and it loads correctly, at least for me. I've confirmed it by using FireBug to analyze all browser requests, and I had no 404 at all.

Do you think you can try FireBug or any similar software to analyze the requests and check if everything is coming correctly from the server?

comment:7 in reply to:  6 Changed 11 years ago by giacobbej

Still seeing the problem on MacOS 10.3.9 and Firefox. As I stated in the previous note I'm NOT seeing the problem on that same machine using Safari, nor do I see the problem in FF under Solaris or FF and IE under Windows. Based on those facts I'm pretty sure the spacer.gif exists on the server and is being passed to the browser (at least the other browsers that work correctly)

I will try to grab a MacOS 10.4.x machine today and see if FF behaves the same way there.

comment:8 Changed 11 years ago by giacobbej

OK, just did some further testing on another MacOS 10.3.9 machine with the same patches and same rev of Firefox (2.0.0.2) and all the toolbar icons look perfect!

The problem must be specific to my machine (and the original poster's machine) but I can't imagine what it could be. Everything else seems to work fine, and I haven't ever seen bogus "empty image" graphics on any other web sites/apps I use.

I guess I'll trying re-installing FF 2.0.0.2 from scratch and see if that helps.

Thanks

comment:9 in reply to:  8 ; Changed 11 years ago by giacobbej

Problem Solved!!!

This was NOT an FCKeditor problem, but rather a corrupted Firefox profile. I created a new profile, copied my bookmarks.html file over, and now all the toolbar icons are displaying perfectly. I'm not sure how or why my Firefox profile got corrupted, or if there is a less drastic fix than creating a new profile, but it worked for me.

FYI, to bring up the profile manager in MacOS, quit Firefox and run the following command line from the Terminal app:

/Applications/firefox.app/Contents/MacOS/firefox -profilemanager

Regards,

Jeff

comment:10 in reply to:  9 Changed 11 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: newclosed

Replying to giacobbej:

Problem Solved!!!

This was NOT an FCKeditor problem, but rather a corrupted Firefox profile. I created a new profile, copied my bookmarks.html file over, and now all the toolbar icons are displaying perfectly. I'm not sure how or why my Firefox profile got corrupted, or if there is a less drastic fix than creating a new profile, but it worked for me.

Great! Do you have a backup of your old profile that you would now mind to share with us? We don't need the bookmarks stuff, but maybe there is something else that could point us to the problem.

Probably you have just destroyed it, but at least we now know how to solve the issue. Thanks for the update!

comment:11 Changed 10 years ago by dorycolbert

Thanks for the help, I reinstalled Firefox and it's displaying website images now. I'm using Mac OS 10.3.9 with Firefox 2.0. I'd have to switch back and forth from Firefox to Safari because a lot of the web sites I'd visit would not display images when using Firefox.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy