Opened 11 years ago

Closed 9 years ago

Last modified 9 years ago

#2365 closed Bug (worksforme)

Can't Add URL to Image

Reported by: spgard Owned by:
Priority: Normal Milestone:
Component: UI : Dialogs Version: 3.4.1
Keywords: Opera Cc:

Description (last modified by Krzysztof Studnik)

Seems to be very similar to Ticket 396, but I could duplicate it on the demo site and the nightly build using Opera 9.51, Build 10081 on Win XP SP 2.

  • Add any image, such as a smiley.
  • Highlight the image and click the Insert/Edit Image button.
  • Click the Link tab.
  • Enter http://www.yahoo.com (or any URL).
  • Click OK. Nothing happens.

The error console says:

JavaScript - http://www.fckeditor.net/fckeditor/2.6.2/editor/fckdialog.html [[BR]]

Event thread: click[[BR]]

Error:[[BR]]

name: TypeError[[BR]]

message: Statement on line 82: Cannot convert undefined or null to Object[[BR]]

Backtrace:[[BR]]

  Line 82 of linked script http://www.fckeditor.net/fckeditor/2.6.2/editor/dialog/common/fck_dialog_common.js: In function SetAttribute[[BR]]

    		element.setAttribute( attName, attValue, 0 ) ;	// 0 : Case Insensitive[[BR]]

  Line 265 of linked script http://www.fckeditor.net/fckeditor/2.6.2/editor/dialog/fck_image/fck_image.js: In function Ok[[BR]]

    		SetAttribute( oLink, '_fcksavedurl', sLnkUrl ) ;[[BR]]

  Line 663 of inline#1 script in http://www.fckeditor.net/fckeditor/2.6.2/editor/fckdialog.html[[BR]]

    		if ( frmMain.Ok && frmMain.Ok() )[[BR]]

  Line 1 of function script [[BR]]

    Ok();[[BR]]

  ...
stacktrace: n/a; see 'opera:config#UserPrefs|Exceptions Have Stacktrace'

The cause of the failure seems to be that the line:

oLink = oEditor.FCK.CreateLink( sUri )[0] ;

returns undefined.

Change History (4)

comment:1 Changed 11 years ago by Wojciech Olchawa

Component: GeneralUI : Dialogs
Keywords: Confirmed added; Image Link removed
Summary: Can't Add URL to Image in Opera[Opera] Can't Add URL to Image
Version: SVN

Confirmed in Opera 9.5.1

comment:2 Changed 9 years ago by Krzysztof Studnik

Resolution: worksforme
Status: confirmedclosed
Version: SVN (FCKeditor) - Retired3.4.1 (SVN - trunk)

Works for me on Opera 10.61.3484, CKE 3.4.1 Trunk & demo

comment:3 Changed 9 years ago by Krzysztof Studnik

Description: modified (diff)
Summary: [Opera] Can't Add URL to ImageCan't Add URL to Image

comment:4 Changed 9 years ago by Krzysztof Studnik

Works For Me also in Opera 10.61 Linux

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy